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Thank you very much for choosing Nikon.
This manual explains installation and use of the NIS-Elements Advanced Research. For
trouble-free operation, read this manual before using the program.

No part of this manual may be reproduced and transmitted without Nikon’s permission.
The content of this manual is subject to change without notice.
Nikon has carefully prepared this manual. However, we make no expressed or implied
warranty of any kind and assume no responsibility for such errors or omissions.
Be sure to read the instruction manuals for the microscope and PC you plan to use with the
NIS-Elements Advanced Research.

Trademarks:
Microsoft®and Windows®are either registered trademarks or trademarks of Microsoft
Corporation in the United States or other countries.
Products and brand names are trademarks or registered trademarks of their respective
companies.
The “TM” and ®marks are not used to identify registered trademarks and trademarks in this
manual.

To run NIS-Elements Advanced Research optimally, the following specifications are required.
Minimum PC Specification:
CPU: Intel Core 2 Duo or higher
RAM for 32bit OS: 2GB or higher
RAM for 64bit OS: 4GB or higher
Operating system: Windows 7 Professional SP1 32bit/64bit (English)
HDD: 2GB or more of available hard disk space for installation
Display: 1280x1024 pixel (True Color mode)
User rights: Administrators for installation
* Operation cannot be guaranteed on all computer models. For further information, contact
your nearest Nikon representatives.
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Installation and Startup

1. Installation and Startup
1.1. NIS-Elements AR Installation
Quick Guide
• Insert the installation DVD in the DVD-ROM drive. A window automatically appears.
• Install the selected NIS-Elements AR software version, additional modules, and device drivers.
• Plug the provided HASP key into the USB port of your PC.
• Run NIS-Elements
The Installation DVD-ROM Content
The installation DVD-ROM contains:
• NIS-Elements software setup file
• Drivers and utilities for the HASP Key
• Drivers for selected cameras
• User's Guide in the PDF file format
• Sample image database
• Sample ND2 image sequences
The Installation Process
Caution
You have to possess the administrator rights to your computer to be able to install NIS-Elements AR
successfully.
1)

When the installation DVD is inserted, a selection window appears automatically.
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Select the software package to be installed. Select the one you have got the license for and which is
properly coded in your HASP key. The installation wizard welcome-window appears. Click [Next] to
continue.
2)

Select whether to install [Local Option] or not. Define the folder where NIS-Elements AR should be installed. We recommend to use the predefined directory. If you want to change the directory anyway,
press the [Browse] button and select a new one. Otherwise click [Next].
Note
The [Local Option] installation provides some advanced features which did not pass the
quality assurance procedure yet. We recommend to wait until they are released officially.
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3)

Now, select the cameras which will be used with NIS-Elements AR.
4)

If your licence contains some additional modules besides the NIS-Elements AR core software, please
select them in this window.
Note
Any module selected will be installed along with NIS-Elements AR automatically. However,
you might not be licensed to use it. The module will run after you get the corresponding code
registered in your HASP key.
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5)

Select the devices which will be used with NIS-Elements AR. Finish the installation by clicking the [Install]
button.
Note
NIS-Elements may not be connected to devices after installation depending on the PC status
at installation. If so, execute the [Modify installation] command of the Windows Start menu
(see the next step) to perform [Repair] that corrects the previously installed status.
6)

The setup creates a new program group in the [Start] menu containing the following items: NIS-Elements
AR application shortcut, the HASP key information shortcut, the [Modify Installation] shortcut (for adding
hardware drivers, modules, etc.), the [Uninstall] procedure, and the Send Info Tool. A shortcut to NISElements AR is created on the desktop too. These changes affect all user profiles of your local Windows
operating system.
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Note
Clicking the [Uninstall] command deletes all installed files from disk, and removes the NISElements AR program group from the Start menu as well as it removes the desktop icon.
Additional Module/Device Installation
You may need to install a device or an additional module after the NIS-Elements AR main system installation.
• Go to [Start menu > Programs > NIS-Elements AR] program group.
• Select the [Modify Installation] command.
• Follow the installation wizard instructions. Select the check-boxes by the items you would like to add.
• Finish the installation.
Sample Database Installation
If you chose to install the Sample Database, a new subdirectory “Databases” is created inside the NIS-Elements
AR installation directory (e.g. C:\Program files\NIS-Elements AR \Databases\...). The “Sample_Database.mdb”
file is copied to there along with database images (stored in subdirectories). An administrator username/password to access this database is set to:
• Username: "sa"
• Password: "sa"
Software Copy Protection
The NIS-Elements AR software is delivered with a HASP hardware key.
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The HASP key contains information about the software licence and allows users to run the corresponding
software. Please connect the USB HASP after the NIS-Elements AR installation is finished. The utility called
HASPinfo is installed to the NIS-Elements AR directory. It enables the user to view information about the
software licence and is accessible via the [Help > HASP Info] menu command.

1.2. Command Line Options
When starting NIS-Elements AR from the command line (or when editing the desktop shortcut properties),
you may append some parameters to the main command and thereby modify the startup behavior:

1.2.1. Syntax and Example:
“ NIS-Elements AR executable” [switch#1] [parameter#1] [switch#2] [parameter#2] etc. For example:
“C:\Program Files\NIS-Elements AR \NIS-Elements AR.exe” -f “C:\Images\starting_image.jp2”
This command runs NIS-Elements AR and opens the [starting_image.jp2] at the beginning.
Note
• By default, only one instance of the application is allowed to run. When the application is running
and a command similar to our example is called, it will be applied to this running instance. This
does not apply when the [-q] switch is engaged.
• Some switches do not have parameters.

1.2.2. Switches:
-?
Displays a help screen with the description of switches.
-c “Command”
The application runs the specified NIS-Elements AR macro command.
-f “Filename”
The application tries to open the image pointed to by the [Filename] parameter.
-g “Grabber name”
The image grabber (driver) of the specified Grabber name will be used and no camera-selection window
will show at startup. As the name of the grabber, you can use the name which appears in the startup
driver selection dialog, or the name of the driver class. These are listed in Windows registry
(HKEY_CURRENT_USER):
“Software\Laboratory Imaging\Platform\Platform.INI\CLxGenericProviderGrabber”
Set the parameter value to “last” and the most recently used grabber/camera will be loaded.
-gn
No grabber driver will be loaded. The “passive” version of the software will start.
-h “HW Unit Name”
The specified HW Unit will be used. Two HW Units (e.g. two DS-U2 cameras) can be run by one grabber/driver. The available HW Units are listed in the [Acquire > Select Camera] window. Set the parameter
value to “last” and the most recently used HW Unit will be loaded. When using this option you must also
use the [-g] switch.
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-i “Config Name”
The application creates a registry entry in "Laboratory Imaging\Platform\Config Name" to load from and
save its configuration to.
-s “Settings File”
The application will use the specified Settings File to load and save its settings.
-l “Language”
The application will run in the specified language (if available). Use codes for the names of countries
according to the [ISO 3166-1] standard.
-m “Macro File”
Application will execute the macro file (*.mac) pointed to by the [Macro File] parameter.
-new
If this command line parameter is added to setup executable file, the setup checks if any other setup has
already been installed. If so, the setup restarts and runs in independent mode. The update mode is disabled. This enables to install two or more builds together on one system.
-passive
The application will not connect to any device on startup (NIS-Elements AR will start with blank Device
Manager). Camera selection is not affected by this option.
-p “Position”
The application window will be placed according to the parameter:
• [left], [right], [top], [bottom] - the window is placed on the corresponding monitor screen.
• [monitor N] - the window is placed on the Nth monitor.
• [rectangle (x0,y0,x1,y1)] - the window is placed in the specified rectangle (in workspace coordinates).
The coordinates must be in parenthesis without any spaces.
-q
A new instance of the application will run.
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2. Application Appearance
2.1. NIS-Elements AR Screen
The following items can be found within the NIS-Elements AR screen:

• The top menu bar containing pull-down menus with sets of commands.
• Application tool bars where buttons representing various menu commands are gathered for quick access.
• The status bar at the bottom of the screen displaying useful information.
• Image window tool bars which enable to customize the view of each opened image individually.
• Docked or floating control windows. See the [Modifying Layout] chapter.

2.1.1. Menu Bar
All menu commands are sorted according to their purpose to the following menus:
Main screen
File
Concerns operations with files such as Open, Save, Import, Send, etc.
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Edit
Concerns operations with the current image. Copy, Paste, Undo, General Options and other commands
are available.
Acquire
Concern image acquisition.
Calibration
Concerns image/objective calibration and optical configurations.
Image
Concerns operations with images, color transformations, resizing, etc.
ROI
Concerns operations with user defined regions of interest.
Binary
Concerns operations with the binary layer - contains thresholding and morphology commands.
Measure
Concerns manual and automatic measurement.
Reference
Concerns operations with reference images. To display all reference images, use the [View > Thumbnails]
command.
Macro
Concerns user macros, macro creation, etc.
Database
Concerns database connections, database tables, database backup etc. (requires: [Database] )
View
Gathers commands concerning the appearance of the screen, displayed control windows, zoom, etc.
Devices
Contains commands needed to handle all connected devices (except cameras).
Window
Concerns opened image windows. It enables to select a window to be displayed or select a predefined
windows documents layout.
Applications
Gathers commands of additional modules if there are any installed.
Help
Enables access to additional information about the system such as help, HASP Info, application log, etc.
Organizer
In [Organizer], most of the menus are hidden, but the following is added:
Tools
Contains commands for filtering and sorting images.
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2.1.2. Application Tool Bars
There is a default set of tool bars, each tool bar containing number of buttons. There is also one fully customizable tool bar - the main left tool bar - to which any button can be added. Every button or whole tool bar can
be hidden by user. Please see [Modifying Layout] for further details.

2.1.3. Status Bar
The status bar at the bottom of the screen displays the following information:

The Application Status Bar

1. Available layouts.
Note
The layout Tabs may be hidden when the [Edit > Options > Appearance > Show Layout Tabs]
option is deselected.
2. Type of the current camera
3. The most recently performed command, or the FPS/Exposure info in case of live image.
4. Name of the current objective.
5. Current coordinates of XY(Z) stage.

2.1.4. Image Window
Tools affecting the appearance of the current image (image) are gathered within the image window tool bars.
There are the following buttons by default:
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LUTs
•

[Enable LUTs] button applies LUTs to the image. See [LUTs].

•

[Keep Auto Scale LUTs] button applies the AutoScale command to the image continuously.

•

[Auto Scale] button performs automatic setting of LUTs.

•

[Reset LUTs] button discards the LUTs settings.

•
•

[Show LUTs window] button opens the window with LUTs.
[Pixel Saturation Indication] button turns on/off pixel saturation indication without setting on/off LUTs.
Select the highlighting color from the nearby pull-down menu.

Split Components
•

[Split Components] button turns ON a special view, where color channels of the image are displayed
separately (tiled).
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Zoom Controls
•
•

•
•
•

[Fit to screen] button adjusts zoom to view the whole image within the NIS-Elements AR screen.
[Best Fit] button adjusts zoom to fit the NIS-Elements AR image window in one direction but to fill the
screen.
[1:1 Zoom] button adjust zoom so that one pixel of the image matches one pixel of monitor.
[Zoom In] Increases magnification of the image.
[Zoom Out] Decreases magnification of the image.

General Controls
•

•

•
•
•
•
•

•

•

•
•
•

[Show Probe] button activates the probe. The probe affects histograms, auto exposure and auto white
balance functions.
[Show Background Probe] button activates the background probe. Some commands use the BG probe
data as reference.
[Show Grid] button displays the grid for rough measurements.
[Show Scale] button displays the image scale.
[Show Frame] button displays and applies the measurement frame.
[Turn ROI On/Off] button displays the Measurement Region Of Interest.
[Show Profile] button displays the [View > Analysis Controls > Intensity Profile] control window. It allows
you to specify a linear section in the image of which the pixel intensities graph will be created.
[View LUT Intensity] button displays the scale of intensities used inside the image. It works on monochromatic images or a single image channel.
[Show Annotations] button displays the vector layer which typically consists of annotation objects (text
labels, arrows) and measurement objects.
[View Binary] button displays the binary layer of the image.
[View Color] button displays the color layer of the image.
[View Overlay] button displays the color layer and the binary layer in overlay.
Tip
Right click the icons to invoke a context menu where properties of each tool can be modified.

Status Bar
The status bar at the bottom of the image window displays the following information:
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The Image Window Status Bar

• Image calibration
• Image bit depth (8bit, 12bit, 16bit, etc.)
• Image size
• Pixel coordinates of the mouse cursor along with channel intensities.
• Binary layer value (0 or 1)
• Color mode (RGB, Monochromatic, etc.)

2.2. Modifying Layout
Having a well organized application layout can help you make the work with NIS-Elements AR very effective.
There are the following options on customizing the appearance of NIS-Elements AR:
Custom window placement
The live image, opened images and all control windows (Camera Settings, Measurement, Histogram,
LUTs, etc.) can be arranged inside or outside of the application.
Note
To move the Image window out of the main window, drag the Image window title bar and drop
it when the mouse pointer gets fully outside of the main window. Otherwise, the Image window
would go back into the main window.
Compact window or multiple windows
The control windows as well as tool bars can be floating or docked on sides of the application screen.
Multiple monitor support
The NIS-Elements AR window can be stretched to occupy two monitors. When you switch from different
application, NIS-Elements AR will be activated on both monitors.
Customized tool bars
Tool bar buttons may be added and removed from tool bars.

2.2.1. Layouts
A layout in the context of NIS-Elements AR is a set of options describing the arrangement of control windows,
tool bars, and menu items. Blue tabs representing active layouts appear in the application status bar. The
following layouts are placed there by default:
• [Full Screen]
• [Docked Controls]
• [Measurement]
Other layouts can be added and managed via the Layout Manager. To hide/show the layout tabs within the
status bar, go for [View > Layout > Layout Manager] and (de)select the [Show Layout Tabs] option.
14
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To Create a New Layout

• Modify the current layout so that it suits your concept of work.
• An asterisk [*] appears next to the layout name (to indicate it has been modified).
• Right click the layout tab and select the [Save Current Layout As] or [Save As Default]command. If you do
not need to create a new layout but would like to save the changes made, just right click the current (asteriskmarked) tab and select the [Save] command from the menu.
• Write the new layout name and confirm it by [OK].
• A new tab appears and the layout is saved to the list of layouts.
To Reload Previous Layout Settings
You may want to undo the changes made to the layout. Mostly, it can be done by the [Reload] command. Or
by selecting the [Load Default] command.
• Right click the asterisk-marked (recently modified but not saved) tab and choose the [Reload] command.
The application restores the last saved state of the layout.
• Right click the asterisk-marked tab and choose the [Load Default] command. The application loads the
previously saved default layout.

2.2.2. Layout Manager
Call the [View > Layout > Layout Manager] command. The Layout Manager appears.

2.2.2.1. Layouts
The list of currently available layouts is placed on the left side of the layout manager. Each layout may contain
information about controls, tool bars, menu, and commands to be performed when switching between layouts.

15

The List of Layouts

Modifying the Layout Settings
• Select items within the [Global Layout] list which you want to be shared by all layouts.
• The check marks on the left of the layout names indicate the layout visibility. Select the ones you want to
display in the application status bar.
• If an item within some particular layout is not selected, it means you do not want to customize it and the
global settings - if selected within the [Global Layout] - will be used. If the item is not selected within the
Global Layout either, the settings of the most recently active layout will be used.
• Set whether the layout is [Private] or [Shared]. If set [Private], it will not be visible for other users. See [User
Management].
• Customize each item according to your needs (see below).
Layout Manager Tools
•

The [New] button adds a new layout to the list of layouts.

•

The [Remove] button deletes the selected layout. The first two layouts cannot be deleted.

•
•

The [Activate] button makes the selected layout active
The [Load Default] button loads original settings of the selected pre-defined layout ([Full Screen], [Docked
Controls], [Measurement]) so that it looks just like after the program installation.

•
•

•

The [Apply to All] button ensures that the executed changes will be applied to all layouts.
The [Import] button enables to load a previously saved set of layouts from an XML file. When you try to
import a layout with already existing name, you will be prompted to choose whether: the imported layout
replaces the existing colliding layout, or is not imported, or is imported and renamed.
The settings of layouts can be saved to an external XML file. Use this [Export] button. In the windows
that appears, define the destination file name and check which layouts will be included in the exported xml
file.
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2.2.2.2. Controls
The layout of docking panes and the control windows arrangement has to be modified directly in the application.
The right part of the window provides only the overview of the structure.

Tree View Levels
There are 5 levels in the tree view:
1. [Display] (primary, secondary, etc.)
2. [Docker] (top, bottom, left, right)
3. [Column] (controls can be placed in a docker side by side)
4. [Tab] (one column can take multiple controls “layered”)
5. [Controls] in each tab.

2.2.2.3. Modifying Tool Bars

• Select the [Toolbars] item within the list of layouts. The right-side part of the window changes.
• Choose one of the tool bars which you would like to modify from the [Toolbar] pull-down menu.
• If selected, de-select the [Use Default] option on the right.
• Any button of the tool bar may be hidden by de-selecting it. No buttons can be added to any of the tool bars
except the [Main Left Tool Bar].
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• The whole tool bar can be hidden by de-selecting the [Show Toolbar] check box.
• There are two sizes of buttons available. Select the [Large Buttons] option to use the larger one. This setting
is shared by all tool bars.
Modifying the Main Left Tool Bar
Custom user buttons can be added to the main left tool bar.You can define your own buttons which run single
macro functions or execute macros . Select the [Main Left Toolbar] from the pull-down menu.

Lets say that we very often use the [Image > Contrast] command. It is useful to add a shortcut button to the
tool bar. Press the [Add] button, and choose [Command] from the pull-down menu:
• A new command - [Command0] - is added to the list.
• Now, attach the NIS-Elements AR command: Open the pull-down menu on the right side of the [Command]
edit box and click [Command List].
• A list of commands appears. Choose [_Contrast()].
• Confirm the selection by [OK].
It is possible to create a sequence of commands, by repeating this procedure.
If you are not satisfied with the default icon, you can change it by pressing the [Change] button. A window for
selecting the icon appears. You can select the image from the NIS-Elements AR icon set by default, or load
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some other from any file containing icons (ico, dll). You can define the icon for the command in a disabled
state, too.
It is handy to define a tool-tip (a text that appears when the mouse cursor is placed over the icon) for your
command. Simply write the text into the [Tooltip] box. You can change the position of the command in the
tool bar using the arrow buttons. The [Default] button discards your changes and inserts the default set of
commands to the tool bar.

2.2.2.4. Modifying the Menu
The [Main Menu] and some of the [Context Menus] accessible by right-click within the application window
may be modified. Items of the context menus can be hidden by de-selecting them similarly to the tool bars.
The main menu can be modified as follows:
Modifying the Main Menu

• Select the [Main Menu] in the topmost pull-down menu.
• Any item may be added to the main menu - a [Separator], a [Menu Command], a sub-menu ([Menu Popup]),
and even a new menu ([Main Menu Popup]) - by the [Add] button.
19

• Select the existing menu item under which you would like to place the new item.
• Click the [Add] button and select the item to be added from the pull-down menu.
• Edit the [Item Properties] .
Note
The [Default] button discards all changes and loads the main menu original configuration. The [Remove] button deletes the selected item. The arrow buttons move the selected item up/down. The
[Use Default] check box, when selected, applies the default settings to the menu.
Item Properties
Text
This is the text which appears in the pull-down menu. You may add “&” before any letter - such letter will
be considered a keyboard shortcut when browsing the menu.
Hot key
One or more hot key shortcuts may be assigned to the command. Just press the [Add] button and press
the key combination. Press [Remove] to remove the selected hot key.
Enabled/Disabled bitmap, Command
These fields serve for assigning a bitmap image and a macro function to the menu command. It works
the same way as when modifying the Main Left Tool Bar (described above).

2.2.2.5. Commands
These settings enable to run a command or a macro right before and after you switch to the layout.

2.2.3. Docking Panes
Docking panes are square spaces inside the application window, where you can place (dock) any of the
control windows. There is one docking pane available at the Right, Bottom, and Left side of the application
screen.
To Display a Docking Pane
• Go to the [View > Docking Panes] sub-menu and select the pane you would like to display.
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Note
The [Docking Panes] sub-menu can be also displayed by right-clicking into the empty application
screen.
• The docking pane appears, either empty or with some window(s) docked inside.
• Repeat this procedure to display more docking panes.
Handling Control Windows
Various control windows can be displayed docked within the docking panes or they can be floating. See the
following picture:

The Docked Control Window Caption

To handle the control windows (CWs), you can:
Add CW to a docking pane
Right click inside a docking pane (3) and select the control window to be displayed from the context menu.
If the window is already opened somewhere else (in another docking pane or floating), it closes and
moves to the new destination.
Close CW
Click the [cross] button (2) in the right top corner of the tab.
Drag CW
Drag any CW by the tab and drop it somewhere. If you drop it by the edge of a docking pane, it will create
another column of this pane. If you drop it over the caption of another CW, it will be docked in the same
pane as a new tab. If dropped somewhere else, the CW will be floating.
Note
A color frame appears when you place the mouse cursor dragging a CW over the edge of a
docking pane or a caption of another CW. It indicates that if you drop it, its placement will be
handled automatically.
Minimize the docking pane
Click the arrows in the top left corner. The pane minimizes to a stripe by the edge of the screen. It can
be restored to its original position by double clicking this stripe or by clicking the arrows again.
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Close the docking pane
Click the [cross] button (4) in the docking pane caption. Or you can right click the pane and unselect the
[Docking View] option.
Dock/undock CW
To dock (and undock) a CW, double click its tab.
Display CW
Another way to display a CW is to go to the [View] menu and select the desired control window. After
that, the CW appears on the screen - floating or docked. Positions of the windows are being saved by
the system so that each control window appears in the same position as it was before it being hidden.
The controls are sorted to several groups:
Analysis
Acquisition
Macro
Visualization

Shrink/Expand dockers
Having more docking panes opened, a situation where there is not enough room for the control windows
can occur. In such case, the [Shrink] and [Expand] commands shall be used.

• Right click the pane you would like to shrink/expand. A context menu appears.
• Select the [Expand]/[Shrink] command. When one of the panes shrinks, the neighbouring pane expands
to the emptied corner and vice-versa.
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2.2.4. Appearance Options
General appearance adjustments can be made in the [Options] window. Run the [Edit > Options] command
and switch to the [Appearance] tab.

The following properties can be adjusted here:
• Application background
• Color scheme selection
• Application language
• Save dialog buttons
• Displayed Z dimension value in the status bar
• Availability of Z Intensity control in the application
• Image tool bars visibility and style

23

• Bottom toolbar visibility
• Channel tabs visibility
• Layout tabs visibility
• Task bar visibility
• Initial zoom of images
• etc.

2.3. Organizer
Apart from the main application layout used for capturing and image analysis, NIS-Elements AR provides an
extra layout called [Organizer]. Organizer makes the work with image files and databases as easy as possible.
button located in the top right
To activate it, run the [View > Organizer Layout] command or click the
corner of the application window. The screen opens divided into two identical panes. To switch from one pane
to the other, use the [View > Next Pane (F6)] command. To copy files between the panes, simply drag the
images from one side to the other side.

The organizer layout.

•

This button toggles the display of the directory tree.You can switch it off to get additional space to display
images.

• In the nearby pull-down menu, it is possible to set the file type and only the one will be displayed. Or, [All
Images] can be displayed.
• If the [Subfolders] check-box is selected, all images from included sub-folders are displayed.

2.3.1. Image Filter
You can define a filter which enables you to display only images which fit the defined conditions. One or two
conditions may be applied.
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•
•

Pressing this button invokes the filter setup window.
This button activates the filter.

Basic Mode
This mode enables you to filter files according to one condition.
Advanced Mode
This mode enables you to define two conditions with a relationship between them. Either select [OR] to display
files matching at least one condition, or select [AND] to display files which match both conditions.

1. [Search in field] - select the field where NIS-Elements AR should search for a given expression.
2. If the selected field is of a numerical type (e.g. Size, Calibration, File date etc.) you can specify, whether
you want to find the exact [value] or a value in a given [range]. This is selected by the [Condition type] radio
button.
3. If the field type is [Text] , the [Occurrence] setting determines the way of evaluating the expression:
• [Anywhere] - If the given sequence of characters is found anywhere in the field, the system will evaluate
it as a match. For example: you have entered “set” to the [Values] field. The filter will select records with
the following field values: “set”, “reset”, “settings”, “preset”, etc.
• [Exact] - If the given sequence of characters exactly equals to the content of the field, it is evaluated as
a match. Fields containing the “set” value only will match.
• [Start] - If the entered string is found at the beginning of a field, it passes the condition. For example:
fields containing “set”, “settings”, “setup” will match.
• [All letter strings] - It is possible to search for more expressions. These should be entered separated by
commas. If you want to enter an expression with a space, insert it quoted. If this option is selected, only
records where all of those expressions appear (anywhere) will match.
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• [Any letter string] - This option is for entering multiple expressions as above, but this time every field with
an occurrence of at least one from the given expressions is matched.

2.3.2. Operations with Images
• To open an image double click its thumbnail. NIS-Elements AR will close [Organizer] and display it in the
main window.
• To select multiple images, either click on the first and the last image holding the [Shift] key (continuous
group selection) or click individual images with the [Ctrl] key down.
• You can copy one or more images from one folder to another by “drag and drop”.
• To delete selected images press the [Delete] key.
All those operations and some other can be invoked also from the context menu, which appears each time
you right click on the image thumbnail:

Thumbnail Displaying Options
You can adjust the way images are shown in the organizer.
Thumbnail View
Press this button and select the size of displayed image thumbnails. Selecting the [Details with preview]
option will display images below each other with all available information aside.
Rotating Images
There is a possibility to rotate images from within the organizer. It affects not only the image thumbnails,
but the image data too. Press the corresponding buttons.
Autocontrast
Press this button to turn the [Apply autocontrast to thumbnails] option ON. It enhances the image
thumbnails automatically. Dark images gain details.
Sorting of Images
To order displayed images, right click anywhere in the pane - a context menu will appear. Move to the [Sort
by] sub-menu which offers several ordering criteria. If the ordering is turned ON already, the icon is displayed
on the left side of the applied criterion.
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Grouping of Images
To arrange the view of images efficiently, you can use the capability of grouping of images. Drag the column
name bar to the grouping bar (right above the column name bars). All files with matching field values of the
selected column will be grouped together. This can be undone by dragging the column caption back to the
others. See [fig. The organizer layout.] (the Calibration column is grouped).

2.3.3. Adjusting the Organizer Layout
The pane size is adjustable. To resize it:
1. Place the mouse cursor over the dividing line in the middle.
2. The cursor becomes an arrow with two tips.
3. Drag it left or right to the new position.
Also, the following buttons appear in the top bar:
•
•

Resizes the panes to achieve the same size for both of them.
Resizes the pane to its maximal/minimal size (one pane is then displayed on the whole screen).

2.4. User Management
User management is very useful when a single workstation is shared by number of users. Some user accounts
may have administrator rights to NIS-Elements while other's privileges are quite restricted. A per-person
system may be established or user accounts may be shared. The following principles are utilized within NISElements AR:
MS Windows accounts support
NIS-Elements AR can assign privileges to MS Windows accounts. Whoever is logged in the operating
system and runs NIS-Elements obtains a default set of privileges. System administrator can than further
restrict or extend the user's rights.
NIS-Elements AR password protection
It may be not comfortable enough to log the current user off from MS Windows when a user change is
required in NIS-Elements. For such case a completely independent list of user accounts, which is not
connected with MS Windows users, can be created. Then just restart of NIS-Elements is needed to switch
the user.
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Private vs. Shared storage
Every user-created item (setting) important in the work-flow can be protected from unwanted change in
two levels. First, the creator of the item (optical configuration, layout, objective, etc.) can save it as [private].
Unless its status is changed to [shared], no other user will even see this item within the lists throughout
the application. The second level of protection concerning all [shared] items is provided by assigning
users to [Groups] and [Privileges] groups.
Groups
Every user is a member of a group. The group enumerates shared items (optical configurations, objectives,
etc.) which will be visible for its members. NIS-Elements administrators can create any number of groups
and select the items to be visible.
Privileges
There are basic groups of privileges which allows users or restrict them to perform certain actions. This
concerns for example modifying macros, reports, selecting cameras, etc. There are four levels of privileges
by default, but further can be created by an administrator:
• Admin
• Common
• Guest
• Default
NIS-Elements AR authentication
If you have chosen “ NIS-Elements AR (Password protected)” user authentication method, a login dialog
window appears at every start-up of NIS-Elements AR. Enter a user name and a password for existing user
account. If the option [Allow to Create a New User at Start-up] is enabled, you can create a new user account
without needing an administrator. This account is assigned to the [Default] group of users and [Default] group
of privileges automatically.
Creating a shared layout
Please read the following example on user management. Step by step, we describe the creation of a shared
layout which can not be modified by members of the [Common] and [Guest] groups.
1)

Run the [View > Layout > Layout Manager] command. Set at least one of the defined layouts as
[Shared]. (see [Modifying Layout])

2)

In the left column of the window, select [User Rights]. The following window appears:
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3)

Make sure you are logged as a user with the [Privilege] to [Modify user rights]. If not, use the [Log As...]
button to log in under a different account which has the privilege.

4)

Set layout visibility
Select the [Groups] tab. Here you can see at least one group of items called [Default]. Either select
one a group or create a new one by the [New] button and choose [Layout] within the list of items. All
layouts set as [shared] will be listed on the right side within the [Accessible items] field. Make sure the
check boxes next to the layouts which you allow to be used by the group are selected.

5)

Disable layout modification
Select the [Privileges] tab. Select the group of privileges which should have not the permission to
modify the selected shared layouts. In the [Privileges] field on the right, make sure you de-select the
[Modify Shared Layouts] option.

6)

Apply the new policies
Select the [Users] tab. In the list of users, select the ones which you would like to apply the policy to
(users can be selected one by one or by multi-selection with the [Shift] or [Ctrl] key pressed). Then,
assign the appropriate [Group] and [Privileges] by selecting them from a pull-down menu on the right
side of the window.
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7)
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Confirm the changes by the [Apply] button.
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3. Setting the Hardware Up
3.1. Working with a Camera
This chapter is dedicated to users running the active version of NIS-Elements AR - equipped with a camera.
Let's assume the camera works properly, is connected to the PC with proper system drivers installed and
running (if required by the camera).
Setting Up the Camera
1)
Selecting the Driver
You will be asked to select the camera driver every time you launch NIS-Elements AR.You can change
the driver later using the [Acquire > Select Driver] command. Choose the driver that matches your
camera:

Multiple Cameras
Two cameras can be connected to one system. If this is your case and you intend to use both cameras,
check the [Enable Multi Camera] option and select the [Second driver] from the list.

The following set of buttons appears in the top tool bar when multiple cameras are used:
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2)
Selecting a Camera
Color cameras can be used in a monochromatic mode. The actual camera type (color/mono) can be
selected by the [Acquire > Select Camera] command.
Note
The emulated monochromatic mode is optimized for use with fluorescence specimen where
often only a single-color signal is being captured. The following formula is used to compute
intensity of the emulated mono image:
I = (Ir * Wr) + (Ig * Wg) + (Ib *Wb)
Where: [W] is channel weight calculated from the channel histogram and [I] is channel intensity.
[W] ensures, that channels containing some signal are accentuated while channels without
signal are suppressed. As a result, depending on conditions, the brightness of a monochrome
image might not change even if the lamp light intensity is changed.
3)
Adjust the Camera Settings
Exposure time, camera resolution, and other camera-specific features are adjustable from the [Camera
Settings] window. To invoke it, use the [Acquire > Camera Settings] command.

3.1.1. Live Signal from Camera
Live Formats
A camera format is a set of attributes of a video signal such as: resolution, bit depth, frame rate etc. The live
signal is a stream of image data, coming from the camera to your computer in real time. NIS-Elements AR
provides two different camera modes: [Fast] and [Quality], each serving a different purpose. The format of
both modes can be set within the [Camera Settings] control window.
Live - Fast
This tool bar button runs the [Fast] live mode. This mode is usually set to low resolution, therefore the
frame rate is high. It is used for searching the specimen or when focusing manually.
Live - Quality
This tool bar button runs the [Quality] live mode.This mode should be set to high resolution which reduces
the camera frame rate. It is applied every time the [Capture] button is pressed.

3.1.2. Capturing Images
Although it is possible to perform some procedures directly on the live image, other image operations require
a [captured] or a [frozen] image. If you try to perform such procedure while the live image is active, NIS-Elements
AR will automatically freeze the image. There is a difference between the [Capture] and [Freeze] commands:
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Capture
When pressed, the camera exposure runs till the end of the current frame, and the next frame is captured
and displayed on the screen (it is the first frame with the complete exposure after you have pressed the
[Capture] button).
Freeze
The [Freeze] button interrupts the camera exposure, and displays the very last complete frame.
Note
If you are using the [Fast] mode and press [Capture], NIS-Elements will automatically switch to the
quality mode to capture the image. When the image is captured, it is opened on the screen in a new
image window.

3.1.3. Camera ROI on Live Image
You can specify a camera ROI on a live image by selecting the [Define ROI] command placed in the image
tool bar next to the ROI button. In a window that appears, set the dimensions and the position of the ROI
rectangle. The live image is then restricted to the defined area whenever the [ROI] button is pressed. The
[Save ROI] command enables to save the current ROI to a file whereas the [Load ROI] command loads a
ROI from a file and overwrites the current ROI.

3.1.4. Controlling Cameras by Macro
Every camera can be controlled from within a macro by changing its properties. There is a CameraGet_* and
CameraSet_* macro function available for each camera property (e.g. CameraGet_ExposureTime();). The
number of functions (beginning with CameraSet_ and CameraGet_) and their actual names depend on the
type of camera(s) you have currently connected to NIS-Elements AR.
CameraGet_
The [CameraGet_...] functions retrieve current values of the properties determined by the function name
postfix. So the CameraGet_Exposure(int Mode, double *Exposure); function retrieves the
current value of Exposure of the specified Mode.
CameraSet
The [CameraSet_...] functions allows you to adjust camera properties. So the CameraSet_Exposure(int
Mode, double *Exposure); function sets a new Exposure value for the specified Mode.

3.1.4.1. How to Set Camera Properties
Instead of describing each property function, it is better to show you a universal way to handle a camera by
macro:
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1)

Display the [View > Acquisition Controls > Camera Settings] control window and find the property you
would like to control.

2)

Make a change of the property from within the control window. For example, change the exposure
time.

3)

Display the [View > Macro Controls > Command History] window and see the last function which has
been called and its parameters (e.g. CameraSet_ExposureTime(1, 500);). This is the function you will
control the exposure time with.

4)

Experiment with the camera control window in order to determine the right parameter values of the
functions to be called within your macro.
Note
See the [Function Reference > Acquire > Camera > Properties] section of the online help. Some of
the most common functions are described there.

3.2. Camera Settings
A digital camera mounted to a microscope port or a macro-scope stand records images of the observed scene
on a light-sensitive sensor, and transfers them to a computer. NIS-Elements AR supports various cameras
differing from each other in resolution, frame-rate, sensor type, etc. Despite these differences, controlling
different cameras is similar. The following features are included in the [View > Acquisition Controls > Camera
Settings] window depending on a particular camera type.
Common Settings
Fast (Focus)/Quality (Capture) Formats
Usually, cameras can provide several image resolutions. NIS-Elements AR enables to create two presets
of the resolution settings - [Fast] and [Quality] . The formats then differ in image size, and consequently
in frame rate (number of frames per second - fps). The higher the resolution is, the lower frame rate can
be achieved. Available resolutions depend on the camera type.
Note
When switching between the formats while observing the live image, the size of the image on
the screen is maintained - the zoom setting is changed instead. Only in some special cases,
the behavior changes and the image size is changed instead of the zoom setting which is
maintained.
Binning
The binning mode provides considerably enhanced camera chip sensitivity by integrating more elements
(pixels) together. E.g.: [binning x4] integrates the signal from the area of 4x4 chip elements to one pixel
of the resulting image. Smaller resolutions and faster frame rates are achieved using the binning modes.
Exposure Mode
Exposure mode sets how the Exposure time is calculated. Generally, there are automatic and manual
modes:
• [Auto Exposure] - Calculates [Exposure] time and [Gain] in order to achieve optimal brightness of the
scene. Image quality is the priority, therefore longer exposure times are being preferred. In most cases,
the auto exposure can be run once by pressing the [Auto Exposure] button, or continuously by selecting
the nearby check box.
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Note
Depending on particular light conditions, the result of [Auto Exposure] may not be optimal for
image acquisition.
Warning
You can use one optical configuration when working with live image and switch to another
optical configuration just for the image acquisition (very often, this is performed automatically
i.e. by a macro command). If the “on-acquisition” optical configuration has the [Auto Exposure]
camera mode turned ON, it may produce over/under-saturated images. Since the Auto Exposure algorithm estimates the optimal exposure time by analyzing last several frames, it is not
able to make the estimation correctly if the change of optical configurations would cause significant change in image brightness.To prevent this, we recommend to use [Manual Exposure]
mode in the optical configuration used for capturing.
• [Manual Exposure] - User selects both [Exposure] time and [Gain] manually.
Exposure
When in [manual exposure] mode, this option controls the exposure time, which is expressed inversely
(1/x second). It is the time of charge accumulation in a camera chip between two adjacent frames. Prolonging the exposure time increases the brightness of the image as well as the image quality (the less
gain, the less noise), and decreases frame rate.
Gain
Controls the sensitivity of a camera. Increasing the gain increases brightness of the image, but decreases
quality (the more random noise, the more streaky noise and color unevenness), and increases the frame
rate indirectly by enabling shorter exposure times.
Averaging
Averaging is a commonly used technique of decreasing noise in the image. In this method 2, 4, 8 or 16
consecutive frames are averaged together.
Offset
Sets the brightness of the image. It is a constant additive (positive or negative) changing all pixel values
of the image. With negative offset value the dark image areas become pure black. Considering fluorescence
microscopy, an appropriate offset setting can create continuous black background and thus help to enhance
(together with gain or illumination enhancement) the contrast.
Contrast
Affects dynamics of how the luminosity is rendered. There are several modes for different illumination
(contrast) scene situation.
Gamma
The gamma correction maps the intensity of live signal exponentially to the gamma parameter. For gamma
< 1, dark portions of the image are enhanced whereas for gamma > 1, image parts of higher intensities
are enhanced.
AE Compensation
In automatic exposure modes, the compensation affects how optimum exposure settings (Exposure time
and Gain) are calculated. The Compensation value is expressed in Exposure Values (EV). Setting the
compensation to + 1.0 EV makes the image twice brighter (e.g. doubles the Exposure time or Gain).
AE Lock
This option makes the automatic exposure mode to lock the current exposure settings (Exposure time
and Gain).
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Sharpness
Some camera settings provide the sharpness control which affects how sharp edges in the image appear.
Too much sharpness leads to oversaturated edges.
Hue
Hue shifts image colors across the rainbow.
Saturation
The amount of saturation determines how colors are rendered. More saturation produces richer colors.
Less saturation makes the colors gray.
White Balance
There are usually Red, Green and Blue Gain properties that control how colors are rendered. It is used
to eliminate a color cast from white areas.
Auto White Balance (AWB)
The AWB button performs an automatic white balancing. It adjusts the red, green, and blue image components in order to get a neutral white color.
Advanced Settings
Separate Channel Settings
Having a color camera, influence of the settings described above on each color channel can be adjusted.
In such case, three edit boxes with the default values set to 1.0 are displayed below the feature setting.
These values determine the influence of the feature on each color channel.
Using Probe
enables you to determine a small image area that serves as the data source area for LUTs,
The probe
histogram etc. It also affects the AWB (auto white balance) and the AE (Auto Exposure) features of the
cameras that support it. When the probe functionality is not supported, the AWB and AE algorithms are
computed from the whole image.
Live Acceleration
Would you like to increase the frame rate of the live signal? Move the slider to a desired multiplier. The
system then automatically shortens the exposure time (so the frame rate rises), and the loss of intensity
is compensated by gain (software multiplication).
Target Maximal Intensity
Restricts the maximal image intensity after the auto exposure was applied. The value represents a percentage of the whole camera dynamic range.
Maximal Exposure
This is a safeguard of the time of the Auto Exposure. For quick exposure, it is convenient not to set this
value too high.
Overillumination Tolerance
Sets how many pixels should be white after the Auto exposure is performed. Use lower values (0.01%)
for very bright (shining) objects (fluorescence). For common bright field, even 1% may be a good value.
Optionally, you can define the absolute number of white pixels.
Use Current ROI
The currently defined region of interest, set by the [Define ROI] command, can be switched ON/OFF by
checking this item.
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3.3. Connected Devices
Before you get to work with NIS-Elements AR, all hardware accessories should be connected properly to the
system. In most cases, the following basic procedure is sufficient to connect a device successfully:
• Install NIS-Elements AR, and select the appropriate device(s) during the installation.
• Connect the device to the PC and switch the device ON.
• Run NIS-Elements AR, and run the [Devices > Manage devices] command to open the Device Manager.
• Use the [Add] button to add the device to NIS-Elements AR.
• Select the device from the list of installed devices and press the [Connect] button.
• Select logical devices to be activated.
• Configure device-specific settings using the [Configure (physical) Device] and the [(logical) Device Parameters] buttons.
• [Close] the Device Manager.
Note
MULTIZOOM AZ100M, ECLIPSE LV series, ECLIPSE MA200, or ECLIPSE L200N/300N microscopes
can not be connected from NIS-Elements AR while the setup tool of each microscope is active. To
connect any of these microscopes to NIS-Elements AR, exit the setup tool and then run the NISElements AR.

3.3.1. Logical Devices
NIS-Elements AR handles hardware accessories using the concept of logical devices. There are features of
different hardware devices which equal and therefore can be controlled equally. Such features are called
“logical devices”. A typical logical device is [Stage XY]. Different microscopes can be equipped with different
XY motorized stages, although - regarding the user interface - they behave equally. One physical device (a
piece of hardware) can contain one or more logical devices the list of which appear in the Device Manager
after the connection is established.
Available Logical Devices
Analyzer
The analyzer is a polarizing filter placed in the optical path between the specimen and the lamp. The logical device offers two states: ON (inserted) and OFF (extracted).
Aperture
This logical device is used for controlling apertures in the light path. It is used in complex microscopes
rather than as a standalone device. Two parameters can be typically set for aperture devices, the state
(ON/OFF) and aperture size.
Condenser
A condenser is a two-lens combination located next to the illumination source in the optical path. Its
purpose is to collect light and direct it to the specimen being examined. The corresponding logical device
relates to a changer of different condensers.
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Filter
This logical device controls filter changer movements. There can be several filter changers connected to
NIS-Elements AR at a time. Each filter changer needs to be set up - filter types shall be assigned to positions of the changer:
• Display the filter changer control window ([Devices > Filters and Shutters] or [Devices > Microscope
Control Pad]).
•

Click the settings button

, a window appears.

• Select one of the available positions which the filter will be assigned to.
• Click the [...] button, a list of available filters appears.
• Select the filter name from the list and confirm it by [OK].
• The filters can be moved within the already defined positions using the [Up/Down] arrow buttons.
Note
When browsing the list of filters, details about the currently selected filter are displayed on the
right side of the window.
Illuminator
This logical device is used for controlling the specimen illumination remotely. There is no standard dialog
box for the illuminator control. Each device handles this logical device via a user interface specially designed for it - typically containing one button for switching it ON/OFF and a slider for regulating intensity.
Light Path
Some microscopes have more than one port where it is possible to attach a light source or a camera.
This logical device can switch the illumination between these ports.
Microscope
This logical device is used to group standalone logical devices used in certain microscopes. To control
the logical devices of a microscope from one control window, select the [Devices > Microscope Control
Pad] command.
Nosepiece
This logical device serves for controlling microscope objective changers. There can be three nosepiece
types attached to a microscope:
• [Manual] - it can not be controlled via the software.
• [Intelligent] - the current nosepiece position is read by the application, but can not be controlled.
• [Motorized] - such nosepieces can be fully controlled via the [Microscope Control Pad] or the [Nosepiece]
control window.
See Assigning objectives .
ND Filter
A neutral-density filter is a light absorbing filter whose absorption spectrum is moderately flat. It is used
to reduce the illumination intensity within the optical path.The logical device offers two states: ON (inserted)
and OFF (extracted).
PFS
Perfect Focus System - this logical device corresponds to the PFS physical device available with Nikon
TE2000/TI microscopes.
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Shutter
This logical device can control shutters installed in your system. This device is handled via the [Devices
> Filters and Shutters] control window or straight from the microscope control pad. You can select the
type and rename the shutter by running a contextual menu command either within the [Filters & Shutters]
control window, [Device Manager] window, or in the main tool bar.
Note
There was a restricted number of shutters which could be connected to the system in previous
releases of NIS-Elements AR and they were identified by [Type] (DIA, EPI, Aux1, etc...). The
current version supports identification of shutters by custom [Names], but the [Type] attribute
can be still found in some windows (or used in some macro functions). This is to ensure backward
compatibility.
Zoom
This logical device is used for controlling the zoom factor. Run the [Devices > Zoom Configuration]
command to adjust the zoom settings.
Stage XY
Stage XY enables the movement of specimen within X and Y axes. The system offers user to control
stage movements.
Stage Z
The Z Drive device enables movement throughout the Z axis direction.
TTL/Analog Input, Output
There are six more logical devices available when the NIDAQ controller set is installed: TTL Input, TTL
Output, Analog Input, Analog Output, Calibrated Analog Input, Calibrated Analog OutputEach of these
logical devices represents a connection to an external device which can receive (send) signals from (to)
NIS-Elements. The number of available connections depends on the actual NIDAQ card.

3.3.2. Tips
Assigning objectives
•

To assign an objective to a position or to change an attached objective assignment, click the setup
button in the [nosepiece]section of the microscope control pad.

• A window appears which enables you to select one of the available objectives to the corresponding position.
• Each objective has its specifications displayed in the table. These specifications are not editable.
Motorized Stage Initialization
A motorized stage being initialized could strike the objective. Before initializing the stage, make sure that the
objective is away from the stage. If a motorized Z drive is available, use the [Devices > Objective Clearance
] command to prevent this.
Using two independent Z Drive devices
Workstations can be equipped with two independent Z drive systems, one coarse (slow) and the other fine
(fast). Typically, the first one is used for specimen manipulation in Z axis, when changing objectives, etc. ,
the second one is used for auto-focusing. The following text explains how NIS-Elements handle the two Z
drives.
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Absolute Z
The current positions of both Z drives (Z1, Z2) and the absolute Z position (sum of Z1 and Z2) are displayed
in the main status bar. If there is not enough space to display all these values, only the [absolute Z] value
is displayed (Z1 and Z2 still appear in a tool-tip). The absolute Z value appears in the Z Series Setup.
Active Z
The concept of [Active Z] enables user to select the preferred Z drive:
• The active Z drive is used when performing auto-focus.
• The [Devices > Enable Mouse Joystick Z in Live] command applies to the active Z.
You can select the Active Z device in the [Devices > Mouse Joystick and Auto Focus Z] menu.
Regular Z drive + Piezo Z drive
If you have a regular Z drive and a Piezo Z drive installed, some functionality is added:
• The [Move Piezo Z to] button is added to the [Z Series Setup] window when Piezo Z is selected.
• The [Devices > Keeps Z position and centers Piezo Z] and the [Devices > Move Piezo Z to Home Position] commands appear in the [Devices] menu
The button and the [Devices > Keeps Z position and centers Piezo Z] command provide corresponding
functionality. They move the Piezo Z device to its home position, and compensate this shift by moving
the second Z drive in order to maintain the absolute Z position.

3.4. Optical Configurations
Typically, laboratory computer image analysis systems consist of a computer, a camera, and a microscope
equipped with certain accessories (objectives, filters, shutters, illumination, rotary changers, etc). Most of the
mentioned microscopic hardware is often motorized and therefore can be controlled via NIS-Elements AR.
In addition, it is possible to integrate single settings of all these devices into one compact set called [Optical
Configuration]. It is recommended to create several optical configurations containing particular devices settings.
Then a single click can completely change the current hardware configuration.
Creating New Optical Configuration
1)

Please check that all the devices (microscopes, cameras, etc.) which you want to associate with the
new optical configuration are properly attached to the system and working.

2)

Choose the [Calibration > New Optical Configuration] command. The following window appears. Adjust
the settings of the devices to match the intended state which will be saved to the optical configuration.
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3)

Type the name of the new optical configuration to the [Name] field. Use a short descriptive name, the
name is used on the button in the main tool bar when you select the [Show on toolbar] option.

4)

In the left column, select which device settings to associate with the Optical configuration.
Camera setting
A list of the current camera properties appears on the right. It is being updated dynamically.
Channel setup
These settings determine how channels of newly captured images will be named and what color
will be assigned to them.The available properties depends on the current camera setup (color/mono,
triggered acquisition engaged or not, dual view engaged or not, etc.). In the mono camera mode,
you can either assign the name, the emission length and color to the channel [Manually], or leave
this task to NIS-Elements AR (the [Automatically] option). In such case, information of the light
path (emission wavelength) will be used to determine the channel name and color.
Microscope setting
If there is more than one shutter available and you would like to associate a shutter with the optical
configuration, select which one is the [Active Shutter] from the pull-down menu. Select which parts
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of the microscope shall be included in the configuration by checking them in the [Used devices]
dialog box.
Objective
An objective mounted to a motorized nosepiece can be included in the configuration. Select the
objective from the pull-down menu. Objectives which are currently assigned to any position of the
nosepiece are listed. See [Objectives].
Note
The objective must be assigned to a nosepiece position via the microscope control pad
or the nosepiece control window beforehand.
5)

If some of the device settings still need to be adjusted, click the [Camera & Devices Controls] button
and select the appropriate control window from the pull-down menu. Adjust the settings within the
control window, the optical configuration will be updated automatically.

6)

Click [Finish] to save the new optical configuration and to close the window.

7)

You can create more optical configurations by repeating the procedure. The optical configurations are
saved to registry immediately. A backup of optical configurations can be made by running the [Calibration
> Optical Configurations] command and clicking the [Export] button.

Managing Optical Configurations
To display the optical configurations manager window, run the [Calibration > Optical Configurations] command.
You can make the following actions from the window:
• Create, duplicate, rename, delete, copy settings and switch between optical configurations.
• Modify optical configuration properties.
• Import and export optical configurations to/from an XML file.
Operations with Optical Configurations
Once created, the configuration appears in the list and can be shared with other users by changing the [Private]
option to [Shared] (see [User Management]). The following operations can be performed on the selected
configuration:
• It can be deleted by pressing the [Remove] button. A confirmation dialog box appears.
• Its name can be changed by the [Rename] button. A button with the configuration name appears in the tool
bar (if the [Show on toolbar] option is selected).
• The configuration settings may be transferred to another optical configuration by the [Copy to] button. Press
the button and select the optical configuration to be overwritten with the current one.
• A copy of the configuration can be made via the [Duplicate] button.
• The configuration can be applied to by the [Set As Active] button.
• The settings of all optical configurations can be exported to an external XML file using the [Export] button.
• The previously exported optical configurations settings can be loaded from the XML file via the [Import]
button.
• The list of optical configurations can be ordered manually using the arrow-up and arrow-down buttons.
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• Each configuration can be arbitrary modified within the right-side portion of the window.

3.5. Objectives
If you want to perform measurements on captured images it is wise to calibrate all objectives used to capture
images. Whenever an image is captured through a calibrated objective, the image inherits its calibration.

3.5.1. Managing Objectives
Run the [Calibration > Objectives] command. The [Objectives] window appears:

A list of used objectives can be created within the Objectives window. For each objective, the objective name,
icon next to the
position in the changer, storage status and the calibration are displayed. A [Calculator]
calibration value indicates that the calibration has been calculated from objective properties. If the calculator
icon is missing, the calibration has been performed manually. Use the buttons on the right side to manage
the objectives:
Insert
Click the button and select one of the predefined objectives from the list ordered by magnification.
New
Press this button to create a custom objective. The new objective will be added to the list. Then, define
the [Main properties] and the [Physical properties] of the objective.
Duplicate
If zoom is used, the objective calibration must be re-calculated accordingly. Use this button to make a
copy of the objective and define the zoom factor in the window which opens.
Remove
This button deletes the selected objective.
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Recalibrate
Starts the calibration of the selected objective. See [Objective Calibration].
Export
Enables you to export the complete list of objectives to an XML file. The standard [Save As] window appears.
Import
This button enables you to import a complete list of objectives from an external XML file previously created
by the [Export] button.
Current Unit
This button invokes a pull-down menu where units for the whole application can be selected.
Help
Displays a help page to the [Calibration > Objectives] command.
Edit the properties of the selected objective in the bottom part of the window. Press the [Close] button to finish
this window.

3.5.2. Objective Calibration
After you press the [Recalibrate] button in the [Objectives] window or when creating a new custom objective,
the following window appears:

Select one of the calibration methods:
• The [Manual] calibration lets you draw a distance into a picture and assign real length to it (see below).
• If a motorized XY stage is available, the [Auto] and [4 points] automatic methods appear.
Press [OK] to continue...
Manual Calibration
1)
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When performing a manual calibration, the live image starts automatically and the following window
appears:
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2)

Select one of the icons to draw a distance to the image. If you know the precise calibration value
(px/unit), press the [Pixel Size] button to enter the real size of one pixel:

Enter the calibration value, select units, and confirm the calibration by [OK]. If you do not know the
pixel size, you will have to continue with the calibration on live image:
3)

Insert a calibration slide to the microscope stage.

4)

The distance is defined by placing lines (Horizontal, Vertical, Parallel) to the image. Choose the orientation of the lines by pressing the appropriate button.
Note
If you are sure the camera angle is 0, 90, 180, or 270º, it is recommended to select either
vertical or horizontal lines. Otherwise, select the parallel lines.

5)

Click into the image to place the first line. Place the second line in the intended position by another
click.
Note
You can modify the line position while holding the mouse button. After you release the button
no further changes can be made. When “Parallel lines” were selected, draw the first line by
clicking twice inside the image. The line can be moved and adjusted arbitrary by mouse. When
satisfied, finish the first line by right-click. The second line can be placed by another click to
the image, this time only to adjust the distance from the first line. The process is completed
by right-click.

6)

The following dialog box appears:
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7)

Enter the distance between the two lines and select correct units.

8)

Press [OK]. The objective is calibrated now.

Automatic Calibration
The automatic calibration requires a motorized stage. Select one of the following methods:
Auto
The [Auto] method is fully automatic. NIS-Elements AR moves the motorized stage, acquires two images,
and calculates the calibration from the shift of the images. The auto-calibration performs an estimation
of the real relay lens zoom factor. If the estimation does not match the value specified within the optical
path window, a warning appears.

Example of the warning message

It is recommended to cancel the auto calibration (click [No]), check the real zoom factor of your relay lens
and check and correct the relay lens settings within the [Acquire > Camera Light Path] command window.
Note
The success of this method depends on the texture of the specimen, its contrast, illumination,
etc. If the combination of these factors is unsuitable, the auto calibration may fail. If it fails, try
the following:
• Move the stage to another area of the specimen to get a better texture
• Improve contrast by setting LUTs.
• Check focus, re-focus if needed.
• Turn on the [Acquire > Shading Correction > Shading Correction] command ON.
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4 points
If you select the [4 points] method, the system draws four points on the screen (subsequently) and asks
user to move one significant part of the specimen to each position. After all four steps are completed, the
calibration is calculated from the moves of the stage.
Calibrate Using Objective
When you have an uncalibrated image, you can use an already calibrated objective to calibrate it. Right-click
the [Uncalibrated] field on the image status bar and choose one of the objectives from the [Calibrate using
Objective] sub-menu. Of course, the same objective which was used to capture the image shall be selected.

3.5.3. Units
NIS-Elements AR supports the following units:
• pixels
• nanometers
• micrometers
• millimeters
• centimeters
• decimeters
• meters
• kilometers
• inches
• mils
If the image is uncalibrated, pixels are the only units available. In case of a calibrated image, it is possible to
select other units which are then used to display all values (e.g. measured length/area). There are two ways
of how to select the desired units:
• Right click the image status bar where the calibration is displayed. Select the units and precision from the
context menu.
• Or, click the [Current unit] button located in the [Calibration > Objectives] command window and select the
units.
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4. Capturing
Having NIS-Elements AR installed and all hardware accessories set up, you can start capturing images. The
simplest case is capturing of single images one by one. There are also other ways of acquiring images and
image sequences, some of them specialized and needing specific hardware. They are described in the subsequent sections.

4.1. Single Image Capture
• Turn the connected camera and other devices ON and start NIS-Elements AR.
• When the application is started display the [Camera Settings] control window ([Acquire > Camera Settings]).
• Switch camera to the [Live-Fast] mode and adjust the camera settings to get the live image clear.
• Focus the objective on the scene you would like to capture the image of.
• Switch to the [Live - Quality] mode and adjust its settings, especially the [Exposure time] and [Format] .
These settings will be used on every image capture.
• Switch back to the [Live - Fast] mode. This is the usual mode for smooth work because less of the hardware
resources are engaged.
•

Capture the image by running the [Acquire > Capture] command (

button on the main tool bar).

• A new image is opened and named “Captured” automatically.

4.2. ND2 Acquisition
NIS-Elements AR being a multi-purpose imaging system can be used as a handy tool to study objects, live
organisms, processes, etc. The universal ND2(N-dimensional) file format is what makes this possible. One
[ND2] file can contain multiple images organized according to what type of acquisition they came from. There
are the following acquisition types:
Note
Each acquisition type gives a name to the corresponding dimension of the resulting ND2 file. For
example, we can speak about two-dimensional TZ ND2 file, which means the file contains the Timelapse dimension and the Z-series dimension.
Time-lapse - T
A sequence of images can be captured over a period of time and create a time-lapse image.
Multi-point - XY
Images from different areas of the slide can be acquired.
Z-series - Z
Several techniques utilize Z-stacks of images. Such Z-stack can be for example converted to a 3D
model of the specimen.
Multi-channel - λ
Fluorescence signals can be captured selectively using excitation an emission filters, each of them creating a different color channel.
Large image - M
(requires: [4D/6D Acquisition] )
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When the area of interest exceeds the camera field of view, you can capture a large image composed
of multiple image frames and let it be stitched by an automatic algorithm.
An nd2 file can be created (captured) either containing one dimension or combining several of them.
• Single-dimensional documents can be created automatically (using motorized accessories) or manually
using commands from the [Acquire] menu.
• To create a multi-dimensional image, use the [Applications > ND > Define/Run Experiment] command (ND
module required).
Common ND Experiment Options
The following options can be applied to all types of ND experiments:
Name of the experiment/phase
You can enter a custom name of the experiment. Also name of the phase is editable.
Auto Focus
Automatic focusing can be used during the experiment. You can select the auto-focus method that best
meets your needs. It can be determined whether the focusing shall be performed at the beginning of the
whole experiment or at the beginning of each phase. The [Define] button shows a window where you can
define parameters of the selected focusing method.
Closing Shutter
The active shutter can be closed between single image acquisitions. Just select the [Close active Shutter...]
option in the experiment window.
Running Macro Commands
You can define a command (or a macro) to be run in various stages of the experiment. Select the timing
in the [Advanced] section of the experiment window and enter the command to be run.
In/Out signals
(requires: [Local Option] ) (requires: [4D/6D Acquisition] )
An ND2 experiment can control some accessory devices and can be controlled by another accessory
devices at the same time. This can be achieved by sending/receiving Analog/TTL signals through an
NIDAQ card. If the NIDAQ PCI card is installed, an extra tab called [Inputs/Outputs] appears within the
ND experiment window. See [Applications > ND > Define/Run Experiment].
Load
Use this button to for a configuration XML file to be loaded. The file with the current configuration can be
created by the [Save] button.
Save
Click this button to save the current configuration of this dialog to an XML file. A standard [Save As]
window appears.
ND Sequence Options
The following options can be applied to time, mutipoint and multichannel sequences in ND experiments:
New
This button adds new step into the sequence.
Select All
Use this button to select all steps in the sequence.
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Clear Selection
Use this button to clear all steps selection.
Move Up
Move Down
These buttons moves the current step up/down in the sequence.
Remove Current
This button removes current step from the sequence.
Remove All
This button removes all steps from the sequence.

4.2.1. Time-lapse Acquisition
Detailed studying of long-lasting processes is enabled by the time lapse acquisition mode of NIS-Elements
AR. The achievable experiment duration is limited by the hardware abilities of your PC only. Invoke the [Acquire
> Capture Timelapse > Capture Automatically] command to set the experiment up:

The [Time schedule] table enables you to define consecutive time phases where duration, interval between
single images, and number of images of the phase can be adjusted. The [Interval], [Duration], and [Loops]
settings are bound together, so you just need to set two of these parameters. The remaining parameter is
calculated automatically. Only the selected time phases will be captured.
The flag mark indicates the Duration/Loops priority. For example: if the camera exposure time exceeds the
defined [Interval] between frames, than the experiment settings are not achievable - only the marked column
will be pushed to be correct. You can set the priority column by clicking on its caption.

4.2.2. Multi-point Acquisition
This window serves for defining XY(Z) points to be scanned during the multipoint capture experiment. This
feature is available when a motorized stage XY(Z) is present in the system. Check the [Include Z] box to display
the Z column. The list of defined points can be saved (and loaded later) to an XML file by the [Save] ([Load])
button.. Run the [Acquire > Capture Multipoint > Capture Automatically] command.
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To Define a Multipoint Array:
• Move the stage to the first position.
•

Press the

[Add New] button. A new line containing current coordinates of the stage appears in the list.

• Move to the next position and repeat the steps until you have all the intended points defined.
To Change a Single Z Coordinate:
• Make sure the [Move stage to selected point] is pressed. This button ensures that the motorized stage
moves to the coordinates of the currently selected point.
• Click inside the line you would like to change.
• Move the Z drive to the new position.
• Click the [<-] button.
Note
The XY coordinates of one point cannot be adjusted (unless you delete it and add a new point).
Offset All
The offset all button can shift the XY coordinates of all points in the same way:
• Make sure the [Move stage to selected point] is pressed. This button ensures that the motorized stage
moves to the coordinates of the currently selected point.
• Select one point of the list.
• Move the XY(Z) stage to a new position (define the offset).
• Press the [Offset All] button.
• The coordinates of all points change - the same shift which you made with the stage is applied to them.

4.2.2.1. Custom Multipoint Definition
When you click the [Custom] button, the following window appears. There are two tabs where properties of
a custom scanning pattern can be defined.
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Well Plate tab
Select the method and set the parameters of the well plate:

Manual
This method will create a pattern which will scan [Rows] x [Columns] fields. The Distance X and Y parameters specify distances between two fields. The scanning will begin at the current position.
Interactive
The interactive method lets you specify the number of fields to be scanned and starts a wizard where
you will specify the top-left and the bottom-right corner of the well plate. The distances between wells
are calculated automatically.
Random tab
(requires: [Local Option] )
Specify area where certain random set of points will be acquired.
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Rectangle
The area will be defined by a rectangle. Define X and Y coordinates of left top corner of the area, width
and height of the area.
Radius
The area will be defined by a circle. Define X and Y coordinates of center of the circle.
Number of Points
Define number of points in the area.

4.2.3. Z-series Acquisition
Automatic capturing of images from different focal planes of the specimen can be performed. Run the [Acquire
> Capture Z-Series > Capture Automatically] command. There are three different approaches of how to set
the experiment:
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There are the following ways of defining the Z drive range:
Range by Top/Bottom Positions and Step
1)

Press the

button, the cube turns blue.

2)

Run the Live camera signal. In case you have two Z drives, select the [Z device] from the pull-down
menu.

3)

Set the Z range: move the Z drive to the top position and press the [Top] button, move it to the bottom
position and press the [Bottom] button.

4)

Define the [Step] size in µm or the number of steps to be captured.
Note
In this mode the [Home position] is assigned to the middle one of all the defined steps automatically
(e.g. for 5 steps, it is the third step, etc.). The [Reset] button discards the Top, Home, and Bottom
positions settings.

Range by Home Position and Range
1)

Press one of the following buttons, the cube turns yellow. The range is defined by the home-position
and the scanning range:
•
•

[Symmetric mode] - Define the [Range] by inserting a value in µm.
[Asymmetric mode] - The range is specified by two values, [Below] - the distance below the
home position, and [Above] - the distance above the home position.

2)

Run the Live camera signal. In case you have two Z drives, select the [Z device] from the pull-down
menu.

3)

Move the Z drive to the position which you would like the Z drive to move around. Press the [Home]
button to define the home position.

4)

Specify the scanning [Range] .

5)

Define the [Step] size in µm or the number of [steps] to be captured.

Defining TIRF position
When the TIRF system is enabled, the TIRF option appears in the right portion of the window. To set the TIRF
position:
• Select the [TIRF] check box to enable TIRF.
• Move the Z drive to the correct TIRF Z position.
• Click the [Set TIRF Pos...] button.
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Using TIRF
• Enable TIRF by selecting the [TIRF] check box within the Z-Series experiment settings
• At least one value of the [Z Pos] column of the Multi-channel acquisition setup has to be set to [TIRF]. (See
[Multi-channel Acquisition].)
Piezo
If a Piezo Z drive device is connected, the [Piezo] button appears in the panel. Use the pull-down menu to
select the action which will be performed upon pressing the button:
Keeps Z position and centers Piezo Z
This option moves the Piezo Z drive to the home position, but compensates the movement by the second
Z drive in order to keep the original absolute Z position(sum of Z1 and Z2).
Move Piezo Z to Home position
Moves the Piezo Z drive to the home position regardless of the absolute Z drive position.

4.2.4. Multi-channel Acquisition
Fluorescence (multi-channel) pictures can be acquired. Run the [Applications > ND > Define/Run Experiment]
command and select the [Lambda] tab. There you can set the multi-channel experiment.

Channels Setup
Specify how many channels are to be captured. Set a descriptive name of each channel and select the optical
configuration that is to be used for its acquisition. If no suitable configuration exists, you can create a new
one by selecting the [<define new>] option from the pull-down menu in the Optical Configuration column. The
[Comp. Color] column specifies the color tone, in which the channel will be displayed.
Manual Capture
The [Acquire > Capture MultiChannel Image > Capture Manually] command runs the live image and displays
a new toolbar with the [Capture] button. After pressing the [Capture] button one channel is acquired. The
number of channels depends on the Multichannel Setup. After all channels are acquired, the [Recapture]
button replaces the [Capture] button. It enables you to capture the multichannel image again. All previously
obtained multichannel data will be lost. To recapture a single channel, select it by mouse and press the [Recapture] button. When satisfied, press the [Finish] button.
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Capture >>
This command opens a new image window with the live image and the Capture button. After pressing
the Capture button one channel is captured. The number of channels depends on the settings of the
[Acquire > Capture MultiChannel Image > Multichannel Setup] window.
Recapture
After all channels are acquired, the Recapture button replaces the Capture button. It enables you to
capture the multichannel image again. All previously obtained multichannel data will be lost. When a
single channel is selected, it can be recaptured separately.
Finish
Press the [Finish] button to complete the multichannel capturing.
Define ROI...
This button appears when the camera ROI function is supported by your camera. Its functionality corresponds to the same button within the Live image window. See [Camera ROI on Live Image]

4.2.5. Combining N Dimensions
The dimensions can be combined together creating an N-dimensional image as the result:
• Run the [Applications > ND > Define/Run Experiment] command.
• The following control window appears:

• Select one or more dimensions (tabs) which should be included in the resulting ND2 file. Above the tabs,
there is a preview of how the nd2 file structure will look like.
• Press the [Order of Experiment] button and select the item which defines the desired order of loops in the
nd2 file.
• Set the parameters of each dimension acquisition.
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• Select whether to save the nd2 file directly to a file or just to keep it in memory to be saved afterwards. To
do so, select the [Save to File] check-box. The path and the file name shall be defined if saving to a file is
preferred.
• Click the [Run now] button to start the acquisition.
Note
When the experiment is finished, a window may appear saying “Please wait. Finishing ND experiment, writing image data to the harddisk”. The [Cancel] button within this window enables you to
abort saving of the file. Only the data which has already been physically written to the resulting
ND2 file will be available (this also concerns the [Recorded Data]).
Z Intensity Correction
The [Run Z corr] button works similar as the [Run now] button, but the acquisition uses defined Z intensity
correction. See [View > Acquisition Controls > Z Intensity Correction].
Save to File
An image can be captured and saved manually after the experiment is finished, or it can be saved to harddisk
“on the fly”:
• Check the [Save to File] box. The window reveals an extra section.
• Insert the [Path] or use the [Browse] button to define the destination folder.
• Specify the [Filename].
Recorded Data
The nd2 file contains various [Recorded Data] which carry e.g. acquisition times of single frames. Some of
them can be recorded optionally:
• Press the [Record Data] button. The following window appears:
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• Select whether to record the data for each frame ([Per Frame]) or with a certain [Frequency].
• The data to be recorded shall be check-marked.
• To view the recorded data of an opened ND2 file, invoke the [File > Image Properties] command and switch
to the [Recorded Data] tab.
ND Experiment Progress
The following window appears while the experiment is running:

The window displays the experiment overall progress, time elapsed from start of the experiment, estimated
remaining time, remaining free space on the disk where the captured nd2 file is being saved, and detailed
messages about the experiment work-flow such as: “waiting for next loop”, “stage moving” etc.
You can control the running experiment by the following buttons:
Next Loop
When the time interval of one time loop is long enough, the system captures all the included dimensions
and waits for the scheduled beginning of the next loop. In such case the [Next Loop] button becomes
enabled and you can click it to start the next time loop ahead of the schedule.
Next Phase
After you press this button, the experiment jumps to the beginning of the next time [Phase] after the current
loop is finished.
Start Phase
Use this button to start the time phase selected in the combo box. Select the phase first and press the
[Start Phase] button.
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Pause/Continue
The experiment can be paused by the [Pause] button. Let it go on by pressing the same button.
Refocus
If there is a need to focus manually, press the [Refocus] button. It pauses the ND experiment and runs
[Live] camera signal.
Finish
This button stops the experiment and saves captured data.
Abort
Use this button to stop the experiment without saving the captured data.
Events
If a remarkable event occurs during the experiment, the user can press a shortcut key and the information
will be saved to the resulting nd2 file.You can define the key-shortcuts after you press the [Events] button.

4.3. Capturing to Ring Buffer
The Capturing-to-RAM technique enables user to record sequences displaying very quick actions - lasting
tens of milliseconds. Make sure that the RAM Capturing buttons are displayed on the [Grabber & Devices
ToolBar] (see [Modifying Layout]), or use the corresponding commands in the [Acquire > RAM Capture] menu.
Set the Ring Buffer Size
The technique uses a ring buffer to store temporary data. The ring buffer is a part of virtual memory that is
being constantly (and repeatedly) filled with the live image data. Depending on how fast the action to be
captured is, you should set the ring buffer size (in seconds).

• Click on the [Settings] button.
• Set the [Time buffered before/after] values. These represent the time before and after you click the [RAM
Capture]

button. The whole time interval will be included in the sequence.

• Confirm it by [OK].
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Turn the Buffer ON
•

Click on the [Circular buffer ON]

button to enable recording of Live image to RAM.

• The ring buffer functionality gets activated.
Capture the Image Sequence
• Press the [RAM Capture] button.
• A new image window containing the captured image sequence opens.
Note
When the Camera is switched to Live mode, the circular buffer (ring) button indicates the buffer
activity. If the [RAM Capture] button is pressed afterwards, the captured image sequence will contain
frames from the whole time interval before and after the button was pressed. If you press the button
while in the Frozen mode or without the time buffer turned ON, only the [Time buffered after] portion
of the sequence will be captured.

4.4. Capturing movies
AVI or MOV acquisition is an easy way of recording actions in real time. It produces *.avi or *.mov video files,
which can be played by any standard video player, so you do not need NIS-Elements AR to view the resulting
video. Please see [Creating Movies].
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5. Image Files
5.1. Composition
5.1.1. Image Layers
The following image layers can be saved within a NIS-Elements AR image.

Annotation layer
In this layer, vector objects are stored. The results of manual and automatic measurements, text labels
and other annotations can be included.
Binary layer(s)
The binary layer is usually the result of thresholding. By thresholding, you distinguish objects of interest
from background. A picture of night sky can make a nice example - shining stars may be “thresholded”
and compose the binary layer. Then, by means of automatic measurement, you can e.g. count them.
More than one binary layer can be placed over one image.
ROI layer
ROIs (regions of interest) is a strong tool for distinguishing objects from background similar to the binary
layer. The advantage over the binary layer is that ROIs are vector objects and therefore provide different
way of manipulation. See [Regions of Interest - ROIs].
Color layer
The color layer contains the image data captured by a camera. It can handle images with the depth of
up to 16 bits per color component. The dimensions of this layer determines the dimensions of the other
layers.
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Note
When saving an image, only some file formats are capable of saving all the layers. The other
image formats will save the content of the color layer only. See [Image Formats].

5.1.2. Image Types in NIS-Elements AR
RGB Images
Images acquired by a color camera typically consist of three components that represent red, green and blue
channel intensities. You can display a single color channel using the tabs located in the bottom-left corner of
the image window. Or, an arbitrary combination of them can be selected while holding the [Ctrl] key down.

Multi-channel Images
These documents usually arise from fluorescence microscopy. Instead of 3 color components (RGB), multichannel images can be composed of arbitrary number of user-definable color channels.
Note
If there is a image that contains more than 8 components, the tabs in the bottom left corner of the
image are replaced by the wavelength dimension, similarly to how other dimension loops of nd2 files
are displayed.
ND2 (multi-dimensional) files / datasets
An nd2 file is usually a sequence of images. One [ND2] file can contain multiple images organized according
to what type of acquisition they came from. There are the following acquisition types, also called dimensions
available: Time-lapse, Multi-point, Z-series, Multi-channel, Large-image. The dimensions can be combined
together.

5.1.3. nd2 files
5.1.3.1. Control Bar
When an ND2 file is opened, its structure is pictured at the bottom of the image window. There is a time line
with all captured images indicated by gray markers.The blue-highlighted marker indicates the currently observed
image. Below the time line, loops of each dimension are indicated by rectangles. In case the multi-channel
dimension is included and the number of channels does not exceed 10, the channels are indicated by the
color tabs at the very bottom of the image window.
Browse the nd2 file by clicking inside the time line. You can also display a single loop by selecting the corresponding blue rectangle. There are some examples, how the nd2 file control bar can look like in different cases:
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A T/Z/multi-channel image with some loops selected.

A T/Z/multi-channel image containing 11 channels and the time line hidden

An HDR multi-exposure image

Playing Controls
Play Sequence
Plays all images of the dimension at selected speed. If a selection is applied, only the selected images
will be included in the playback.
Stop Playing
Stops playing the sequence at the last displayed frame.
Previous Position
Displays the previous frame of the dimension.
Next Position
Displays the next image of the dimension.
Decrease/Increase Playing Speed
Changes the playback speed by one step down/up
Real Time Playing Speed
Sets the playing speed to real-time (as the image was captured).
Maximum Playing Speed for Every Frame
Sets the playing speed to maximum while the display of every frame is guaranteed (when the speed is
set to maximum by the + button, some frames are usually omitted when playing the sequence depending
on your graphic card).
Home Position
Displays the frame of the Z dimension that was set as “home” during the acquisition.
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Event and Selection Controls
Insert Default User Event
This button inserts an event marker to the current frame.
Move to Previous/Next User event
Click these arrows to browse through the frames where user events occur.
User Event Selection
This button selects frames of the ND2 file according to the [Event Playing Range] settings - right click
this button and pick the [Event Selection Range] command from the context menu to view/modify them.
A simple window appears. Define the number of frames/seconds which will be selected around each
event.
Range Selection
Clicking this button selects a user defined range of frames. The selection is done by mouse. A range can
be selected by mouse while holding the [Shift] key down. Single frames can be added/removed while
holding the [Ctrl] key down. Right-click the navigation bar to invoke the context menu. A selection can
be adjusted, deleted, or the nd2 file can be cropped.
Note
ND2 files may contain extremely large number of frames so it may be helpful to omit some of
the frames from the selection. Right click the [Range Selection] button and a context menu appears. It enables you to select every 2nd, 5th, 10th, 20th, 50th, 100th frame. The [Select All
Frames] option selects the whole range of frames as if you have selected the first and the last
time phase with the [Shift] key down, but preserves the [Select Every...] setting.
Disable Selection
Press this button to de-select all frames of the nd2 file.
Tips
• Right-click the selection to invoke a context menu. The selection can be adjusted, deleted, or the nd2 file
can be cropped.
• Detailed info about dimensions will be displayed after you click the leftmost button of the control bar (T>,
Z>, ...).
• Place the cursor over one of the dimensions. A tool-tip which displays statistics of the dimension appears.
Playing options
Right click the speed bar to display the following context menu and select the playing mode.
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The following options can be selected (depending on the dimension type):
Back and Forth
Forward
Backward
Select the direction of playing the image sequence.
Stop on Events
[Play Sequence] button, a dialog
When you check the [Stop on Events] option and then press the
window appears once the first user event is reached. The dialog window displays information about the
reached user event. Use the [Continue] button to continue playing to the next event, or press the [Stop]
button to stop the playback at the current frame. Within the window, you can also select the [Do not ask
again in this session (Always stop)] option, the playing will stop automatically on every user event but
the window will not appear.
Repeat
Select this option for repetitive infinite playback.
Fastest Advance
This option corresponds to the

[Maximum Playing Speed for Every Frame] button described above.

Real Time
This option corresponds to the

[Real Time Playing Speed] button described above.

5.1.3.2. Events
User events can be pinned to any of the frames of the image in order to highlight a remarkable scene. There
are number of event types. Some of them are inserted automatically while the ND experiment is running,
others must be defined by user (by the

button).

Once there is one or more events within the time line, you can manage them via a context menu. Right click
the event marker, a menu appears with the following options:
• Remove All Events
• Event Selection Range
• Event Manager
• Remove Event
• Edit Event
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When you open the [Event Manager], all events within the nd2 file may be edited through the following window.
The time can be put in, and the event type selected from a combo box. See [Time-lapse Acquisition].

5.1.3.3. Views
There are several views which can display the nd2 files in various ways. Some views are available for some
dimensions only. If a view is available for two or three dimensions of the nd2 file, a pull-down menu appears
in the top image tool bar. There you can select the dimension to be displayed.
Note
When you switch the view, a new image window opens by default. This behavior can be changed
within the [Edit > Options] command window so that only one view of a image will be opened at a
time.
Main View
When you open an ND2 file, it opens in this view.
Maximum/Minimum Intensity Projection View
These projections analyse all frames of one dimension and pick pixels with the maximum/minimum intensity values. These pixels are used in the resulting image. (Requires Z or T dimension)
Slices View
This view displays orthogonal XY, XZ, and YZ projections of the image sequence. (Requires Z or T dimension).
Volume View
This view creates a 3D model of the acquired object. (Requires Z dimension)
Tiled View
This view displays frames of the selected dimension arranged one next to other. (Requires Z, T or XY
dimension)
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5.1.3.4. View - Examples
Main View, Max/Min Intensity Projection View

Volume View
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Slices View

Tiled View

5.1.3.5. Synchronizer
Synchronizer enables to compare (run and view) two or more nd2 files at the same time. It automatically
synchronizes view of all documents added to the list. Run [View > Visualization Controls > Synchronizer]:
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• Open at least two nd2 files you would like to observe.
•

Use the [Add All Views]

button to add them to the synchronizer table. In case there are more images
button on each of the images. You

opened which you do not want to add, use the [Add Current View]
can also select the [Add New Views Automatically]
ized.

button to have all newly opened ND2 files synchron-

• The names of all added images appear in the [Synchronizer] window.
All documents added to the Synchronizer are automatically being synchronized.
• Set one of the selected images active.
• Any action regarding the view (Z position, displayed frame, etc.) is performed on the synchronized imagese
as well as on the active one.
• Besides synchronization of dimensions, you can also synchronize LUTs settings of the images by checking
the [LUT] check box. LUTs synchronization works only between LUT-compatible images (images must
have the same number of channels etc.). If the images are not LUT compatible, only the [Keep AutoScale]
and [AutoScale] actions are synchronized.

•

You can select the [Enable LUT synchronization by default]
have the option to synchronize LUTs selected by default.

button. All newly added documents will

To remove an image from synchronizer, click the reset button

placed before its name. To remove all

images from synchronizer, press the [Remove All Views]

button.

5.1.3.6. ND2 Information
Information about current frame of an ND2 document or live image can be displayed using the [Show ND Information] command from the image contextual menu. It displays information about current frame of the ND2
document or live image. All possible information (metadata) are displayed by default.
You can edit which information is displayed in the [Label Properties] dialog window: Right click the ND2 information field and select the [ND Info Properties] command. Use options and tools in this window to customize
the display of the ND information - you can change text properties, type of displayed information, accuracy
of the displayed number up to three decimal places, format of the information, duration of display and other.
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5.2. Working with Image Files
5.2.1. Opening Saved Images
NIS-Elements AR offers several ways to open an image file, using either:
The [File > Open] command
To invoke the Open dialog box where you can select the file to be opened, run the [File > Open] command.
This command is also called when you click the [Open] button on the main tool bar
Organizer
An image can be opened by double clicking its filename within [Organizer]. Run the [View > Organizer
Layout] command [F10] to switch to the Organizer. See the [Organizer].
Recent Files List
You can quickly access the last opened images using the [File > Recent Files] menu.
Open next/previous/first/last Commands
These commands enable you to continuously open the subsequent images from a particular directory or
a database table. The [File > Open/Save Next > Open Previous], [File > Open/Save Next > Open Next],
[File > Open/Save Next > Open First], [File > Open/Save Next > Open Last] commands may be used.
Auto Capture Folder
The [Auto Capture Folder] is a control window that can be displayed by calling the [View > Acquisition
Controls > Auto Capture Folder] command. It displays images within a selected folder. To change the
button in the top left corner of the control window and browse for another folder. Any
folder click the
image of this folder can be opened by a double-click.
Any File Manager
During installation, NIS-Elements AR creates file associations to files that are considered its native format
for storing images (JPEG2000 , ND2). The JPEG2000 (JP2) and ND2 image files can be then opened
in NIS-Elements AR just by double clicking their names within any file manager or the desktop.
Opening Files in Progressive Mode
If the image to be opened (a single frame in case of nd2 files) is too big - so that it can not be loaded to RAM
in one piece - you will be asked whether to open it in a [Progressive Mode]. This means that only a thumbnail
of the image will be loaded to RAM. When zooming-in to view image details, the image data of the particular
portion of the image will be loaded to RAM progressively (piece by piece). Many image processing functions
and commands are disabled in this mode.

5.2.2. Switching Between Loaded Images
Commands for managing the opened images are grouped in the [Window] menu. The recently opened files
are listed in its bottom part. The currently displayed image is indicated by the selected radio button. To change
the current image, select it from the list or use the [Next] or the [Previous] commands (represented by [Ctrl +
Tab] and [Ctrl + Shift + Tab] shortcuts).
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Image windows can be also arranged automatically using the [Tile horizontally] or [Tile vertically] commands.
This will change the size and position of the opened documents and they will be arranged next to each other
in the selected direction.

5.2.3. Closing Images
• The currently displayed image can be quickly closed by pressing the cross button in the top-right corner of
the image window.
• The image can be also closed by invoking the [File > Close] command.
• If you want to close all images, use the [Window > Close All] command.
• If you try to close an image that has been changed, NIS-Elements AR will display a confirmation dialog
box, offering to save the changes.
• Use the [Window > Close All but Current] command to close all opened documents but keep the current
one opened.

5.2.4. Saving Images with UAC
Because of the security enhancement with the UAC (user account control) of [Windows Vista] and [Windows
7], it is not possible to save images in those folders that require Windows administrator user rights. Those
folders are:
• [C:\Windows] and subsequent folders
• [C:\Users] and subsequent folders excluding C:\Users\[login-user-name]
• [C:\Program Files] and subsequent folders excluding C:\Program Files\NIS-Elements AR\Images

5.2.5. Copying Channels by Drag and Drop
Drag one of the channel tabs and drop it:
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• to another image, so it will become a multichannel image;
• inside the NIS-Elements AR application window in order to create a new image
Note
• Even the [All] and [RGB] tab can be copied.
• When extracting a channel from Live image, it does not freeze the camera signal.
ND2 files
1)

Drag one of the channel tabs and drop it by the [left mouse button]. It behaves the same way as if
performed on a single image.

2)

Drag one of the channel tabs by the [right mouse button] and drop it to the application screen. A context
menu appears that enables you to select whether to create the new image from all frames or just a
single frame.

3)

[Two nd2 files] that have matching structure can be [merged into one] easily. E.g. two single channel
Z stacks with the same number of Z positions can be merged into a single two component ND2 Z-stack
by dragging one into the other.

4)

Drag one of the channel tabs of a [single image] and drop it [to an nd2 file]. The channel will be copied
to every loop of the ND2 file.
Note
This behavior, too, takes place when copying channels that do not have matching structure
(just the current frame is copied to every position of the target ND2)

5.2.6. Image Formats
NIS-Elements AR supports a number of standard file formats. In addition, NIS-Elements AR uses its own
image file format (ND2) to fulfil specific application requirements.
JPEG2000 Format (JP2)
An advanced format with optional compression rates. Image calibration, text descriptions, and other metadata can be saved together with the image in this format.
ND2 Format (ND2)
This is the special format for storing sequences of images acquired during ND experiments. It contains
various information about the hardware settings and the experiment conditions and settings. It also
maintains all image layers of course.
Joint Photo Expert Group Format (JFF, JPG, JTF)
Standard JPEG files (JPEG File Interchange Format, Progressive JPEG, JPEG Tagged Interchange
Format) used in many image processing applications.
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Tagged Image File Format (TIFF)
This format can save the same amount of meta-data as JPEG2000. TIFF files are larger than JPEG2000
files but are loaded faster. TIFF files have several ways to store image data, therefore there are many
versions of TIFF. NIS-Elements AR supports the most common TIFF modalities.
CompuServe Graphic Interchange Format (GIF)
This is a file format commonly used on the Internet. It uses a lossless compression and stores images
in 8-bit color scheme. GIF supports single-color transparency and animation. GIF does not support layers
or alpha channels.
Portable Network Graphics Format (PNG)
This is a replacement for the GIF format. It is a full-featured (non-LZW) compressed format intended for
a widespread use without any legal restraints. NIS-Elements AR does not support the interlaced version
of this format.
Windows Bitmap (BMP)
This is the standard Windows file format. This format does not include additional image description information such as author, sample, subject or calibration.
LIM Format (LIM)
Developed for the needs of laboratory image analysis software. Nowadays, all its features (and more)
are provided by the JPEG 2000 format.
ICS/IDS image sequence
ICS/IDS image sequences are generated by some microscopes and consist of two files: the ICS file with
information about the sequence; the IDS file containing the image data. The ICS file must be stored in
the same directory together with the IDS file.
Caution
ND Images containing multi-point XY dimension cannot be saved to a file in the ICS/IDS format.
See also [ND2 Acquisition].
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6. Image Analysis
6.1. Image Processing
6.1.1. Processing On: Intensity/RGB/Channels
You can decide whether to perform the processing on single RGB channels of the image, or on the intensity
component of the image only. The RGB/Intensity setting is global so it is applied to all the other processing
commands automatically. When processing a multichannel image, this option is disabled - the operation is
applied to channels automatically.
Note
In case the command does not open a window where it would be possible to make the choice, the
setting from the last performed processing command (the global setting) is applied.

6.1.2. ND2 Files Processing
Most of the image processing and binary image processing commands can be applied to one frame, all frames,
or selected dimension of the nd2 file. When you use such command with an ND2 file, the following options
are added to the command dialog window:

Current Frame
The operation will be performed on the current frame of the nd2 file.
All Frames
The operation will be performed on all frames of the current nd2 file.
Selection
The operation will be performed on all frames of the selected dimension. If you selected some of the
frames/loops of the nd2 file by mouse, the [Selection] option appears in the pull-down menu. Opt for it to
process only these selected (green highlighted) frames/loops.
Example 6.1.
When you process an image containing T and Z dimensions, selecting the Z-Series dimension performs
the operation on all Z frames of the current T loop.
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6.2. Histogram and Look Up Tables
6.2.1. Histogram
A histogram displays frequencies of pixels of a certain intensity value. The intensity values range from 0 to
255 (for 8bit images). A separate curve is created for each color channel. Run the [View > Visualization
Controls > Histogram] command to display the histogram control window:

Source Data
Source data of the histogram can be viewed if you swap to the [Data] tab in the bottom-left corner of the
window. The area from where the histogram is calculated can be restricted according to the selected histogram
mode:

The data are obtained from the whole image.

The data are obtained from within the probe.

The data are obtained from within the current ROI.

The data are obtained from the image parts under the binary layer.
Export
The source data or the histogram image can be exported to an external file. Display the [Export] pull-down
menu and select a suitable destination. Click the button to perform the export. The [Export ND histogram]
button enables to export histogram data of all frames of the current nd2 file. The same destination which is
selected in the [Export] pull-down menu is applied.
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Note
Please, see the [Exporting Results] chapter for further details.
Appearance
The histogram can be zoomed in and out using the zoom buttons on sides of the window. There are also
other options to adjust the graph appearance:
• [Left slider] - there is a slider along the Frequency axis. Drag it in order to stretch the view of either lower
or upper values of the axis.
• [Drawing style] - There are two ways the histogram can be drawn:
• [Raw Data] - tries to draw the source data precisely to the graph
• [Trend Style] - interpolates the data so that the histogram lines appear smoother.
•

•

•
•
•

[Auto Scale Vertical] zooms the graph of each channel separately to fit the available area. When this
function is ON, the histogram is not proportional.
[Auto Scale Horizontal] zooms the graph so that the marginal zero frequencies, if there are some, are
excluded from display.
[Graph Linear] displays the linear scale on the Y axis.
[Graph Logarithmic] displays logarithmic scale on the Y axis.
[Show Grid] turns ON/OFF the grid in the background.

The graph appearance can be modified. Press the [Options]
settings can be adjusted:

button - a window appears where the following

Colors
Graph background and axes colors can be selected.
Pen Width
Set the width of the histogram(s) line to 1, 2, or 3 pixels.
Fill Graph Area
The area below the histogram line can be filled with the channel color.
Graph Area Opacity
Select the opacity of the Graph Area color in %.
Vertical/Horizontal AutoScale, Show Grid
These options equals the corresponding buttons of the histogram tool bar.
Interpolation method
Select the way of drawing the graph line. The [Linear] (smooth) and [Quick] (precise) options are available.
AntiAlias
Smooths the edges of the graph line.
Horizontal axis always visible
If checked, the axis does not leave the graph area while zooming in the graph.
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Overrun Indication
If certain amount of pixels with maximum/minimum intensity values (black/white pixels) are spotted in the
image, color dots appears above the graph. The color indicates which channel is affected. When you place
the mouse cursor over the dots, a tool tip message appears with details about the percentage of under/overexposed pixels. The percentage limit setting is loaded from the LUTs settings (the color dots do not appear
unless the set percentage of black/white pixels is exceeded).
Note
If the overrun concerns more than three channels (considering multi-channel images), only one white
dot is displayed instead of many color dots.
Memorizing
You can save the current graph to memory and display it later for comparison with another graph.

Displays memorized graph.

Memorizes the current graph. Only one graph can be memorized at a time. If any graph has already been
memorized before, it will be overwritten by the current graph.

Clears the memory.

6.2.2. LUTs
A look-up table is a useful tool for image color and brightness modifications. You can use LUTs to enhance
images for observation purposes so the color modifications will be non-destructive to the image data. LUTs
settings are saved along with the image file. If required, the LUTs settings can be applied to the image data
by pressing the
window.

button. Use the

[Show LUTs window] button in the image tool bar to display the LUTs

The following actions are available within the LUTs window:
• Adjusting the [Gamma parameter]. The gamma curve is drawn in gray over each graph. You can drag the
middle point and move it up or down, or enter an exact value to the [G:] field at the top of the graph area.
• Adjusting the input intensity range. The input intensity range can be restricted by moving the black and
white triangular sliders to the center. All pixels with values outside of the modified input range will be set to
maximum/minimum values and the remaining pixels will be approximated in order to fill the output (full)
range.
Note
This is the way how images can be equalized. For example, if the image is very dark and most of
the histogram is located to the left while the right part of it is flat, you may move the white slider(s)
to the position where the histogram line starts to rise. This will incredibly brighten the image and
reveal details which were previously hidden in a dark.
• You can adjust the histograms height non-proportionally by moving the slider on the left side of the window
up and down.
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Tips
• Right-click the graph area and (de)select [Draw trend style]. When ON, the LUTs curves will be smoothed
to display the data trends rather then represent the actual image data values.
• The position of the black, white and Gamma sliders can be reset by a double click.
Different controls will be available when applying LUTs to monochromatic, RGB, multi-channel or spectral
image. When LUTs are active, the LUTs button in the top-left corner of the image window is highlighted red.

6.2.2.1. LUTs on RGB Images

There are 3 separate windows for each of the RGB channels. All channels are controlled at the same time
by default. To control each channel separately, press and hold the [Shift] key while you drag the sliders or
adjust Gamma.
LUTs Tools
Enable/Disable LUTs
This button applies LUTs to the current image.
Keep Auto Scale
Press this button to run the auto scale procedure permanently (on the live image). When you turn this
button OFF, the settings remain as if the [Auto Scale] button was pressed only once.
Auto Scale
This button adjusts the white slider position of all channels automatically with the purpose to enhance
the image reasonably. If you have selected the [Use Black Level] option from the [Settings]pull-down
menu, the black slider will be affected too.
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Reset All Components
Discard all LUTs settings and turn LUTs OFF by pressing this button.
Settings
Display the pull down menu and select one of the following commands:
• [Brightfield Opacity] - You can change opacity of a brightfield channel. Define the opacity in the
[Brightfield Opacity] dialog window that appears after you run this command.
• [Use Black Level] - Check this item to ensure that the black slider will be affected by the auto scale
functions .
• [Settings] - opens the [Auto Scale Settings] window. See Auto Scale Settings.
Keep Auto White Balance Check Box
Check this option to switch the Auto White Balance functionality permanently (on the live image).
AWB
Press this button to perform the Auto White Balance operation once.
Auto White Balance Color (...)
This button Opens the [AWB Color] window and enables you to select a color shade which the system
shall eliminate (make white). See AWB.
Reset AWB
Discard all AWB settings with this button.
Color Oversaturation
Switch this button ON and the system highlights all pixels with values reaching maximal values. Select
colors to highlight the pixels with in the pull-down menu.

These buttons arrange histograms of single channels next to each other horizontally or vertically.

This button arranges histograms of single channels overlapped. Use sliders at the bottom of the graph
window to amplify or reduce the green/red/blue component display in the view.
Save/Load LUTs
This pull-down menu enables user to handle LUTs settings in various ways. They can be saved to a [*.lut]
file and loaded later. Or, LUTs settings saved along with an image image can be loaded directly from this
image by the [Reuse LUTs from File] command. Or you can copy/paste the settings within the documents
opened in NIS-Elements AR (the copy/paste .
Modify Image Through LUTs
button to apply the LUTs settings to the image data - the original image will be overwritten.
Press this
Until you press this button, no changes are made to the image data.
Auto Scale Settings
Press the arrow next to the [Reset LUTs] button and a pull-down menu appears. Invoke the [Settings] command.
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The [Low] and [High] fields determine how many of all pixels of the picture are left outside the sliders when
[Auto Scale] is applied (0-10%).
AWB
White color in some images may suffer from having a color tint. The AWB (Auto White Balance) mode adjusts
the image to get pure white instead of this tint. Similarly to LUTs auto scale, the AWB function can be used
once, or permanently on the live image. If you know the tint your “white” color has, you can select this color
by the color picker that appears after pressing the [...] button:

Choose the color by mouse. You can also enter the RGB values to the fields below. A preview of the chosen
color appears in the rightmost rectangle.
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6.2.2.2. LUTs on Monochromatic Images

All features mentioned above are also valid for monochromatic images, except that the [AWB] function is not
available. There are some other features added when in “mono” mode.
Gradient
Mapping monochromatic images to pseudo-color gradients is often used to enhance details in the image
which would otherwise not be obvious.This button indicates the currently selected gradient. When pressed,
a pull-down menu appears where you can select the color scheme you would like to use. Try a few of
the schemes to see which one suits best.

The [Manage gradients] command in the pull down menu enables to define custom LUTs gradient. Use
the tools in the [Manage gradients] window to define custom gradients. See [View > Image > Create
Custom LUTs] for detailed description of the tools. The gradient then appears in the pull down menu
ready to be applied.
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6.2.2.3. LUTs on Multichannel Images
LUTs window on two-channel image

Most of features mentioned above are also valid for multi-channel images. There are some other features
added when in “multi-channel” mode. Each channel is controlled separately by default. To control all channels
at the same time, press and hold the [Shift] key while you drag the sliders or adjust Gamma.
When the image contains up to three channels, all channels can be visible at one time and you can handle
them similarly to the RGB mode. When there are more than three channels, only one channel is displayed at
one time. A pull-down menu in the tool bar enables you to select the channel to be displayed.
Next to the channel selection pull-down menu, there is this [Auto Scale] button. By pressing it, the system
will automatically adjust only the current channel settings.

6.2.2.4. LUTs on Spectral Images
When observing a spectral image, the graph inside the LUTs window does not show the image histogram(s),
but reveals another information about the image. Intensity values are on the Y axis and spectra is on the X.
There are two curves in the graph. The top (white) curve displays the maximal intensity and the color curve
displays the mean intensity of each channel.
Note
Spectral image consists of many channels, each representing a single wavelength.
The LUTs behavior depends on the selected displaying mode. There are four displaying modes. You can
select the mode either by a pull-down menu in the LUTs tool bar, or within the image top tool bar.
• [True Color]
• [Custom Color]
• [Grouped Color]
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• [Gray Scale]
In the bottom part of the LUTs window, [Gain] and [Black Level] settings can be adjusted either for all channels
together or for each group separately - depending on the displaying mode. Gain brightens the image and the
Black Level works just like the left (black) on RGB/mono images.
Note
Each slider (gain or black level) offers a range of values to be set by moving it, but any higher value
can be entered in the field next of the sliders.
TD channel
A spectral image can contain additional TD (transmitted detector) channel. Its basically a standard monochromatic image. LUTs settings of this channel appear on the right edge of the LUTs window.
True Color Displaying Mode
You can switch to this displaying mode by clicking the

button located in the image tool bar.

Custom Color Displaying Mode
button located in the image tool bar. You can assign
You can switch to this displaying mode by clicking the
custom colors to sections of the spectrum. Sections (colors) can be added/removed by clicking the [+] and [] buttons placed below the spectral graph. To change the section color, click the button located in the color
stripe. A window appears where you can select the color from a palette or define it by [Hue] or [Wavelength]
settings.
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Grouped Displaying Mode
button located in the image tool bar. This view enables
You can switch to this displaying mode by clicking the
you to reduce the number of channels multiple-times. You can adjust the number of groups by the [+] and [] buttons and also change each channel width by moving the white horizontal dividers. Gain and Black Level
for each group can be adjusted.

Gray Scale Displaying Mode
button located in the image tool bar. The image is
You can switch to this displaying mode by clicking the
displayed in gray scale, but various color gradients can be applied to it.
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6.3. Thresholding
Specifying correct threshold limits is a crucial procedure of the automated image analysis. The point is to
determine which pixels will and which will not be included in the binary layer and thereby distinguish objects
to be analyzed from background. To display the thresholding control window, run the [View > Analysis Controls
> Thresholding ] command. Thresholding can be performed in the following modes:

6.3.1. RGB Mode
The [RGB] thresholding mode is available only if an RGB image is opened. There are two ways how to define
the threshold limits, by choosing reference points within the image, or by defining the limit values for each
color channel.
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To threshold the image use the following tools:
•

•
•

•
•
•
•
•

•

This button invokes a pull-down menu which enables to load/save the current threshold settings from/to
an external file (*.threshold).
This button erases the threshold settings (no binary objects are created).
Single point threshold tool. Select it and click inside the image to define the threshold. The threshold
ranges will be adjusted so the selected pixel will fit inside.
3 point circle tool picks threshold from the radius of 3 pixels.
6 point circle tool picks threshold from the radius of 6 pixels.
Undo - reverses the previous threshold operation.
Redo - returns the threshold as it had been before the [Undo] button was used.
Rethreshold image - use this button to update the binary layer according to the current settings. The
purpose of this button is to obtain the original binary layer in case it has been modified e.g. by a command
from the binary layer.
Keep Updating Binary - press this button to keep the binary layer up-to-date all the time. You may find
this function useful especially when thresholding is applied to the live image.
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•

Threshold ND image - when an nd2 file is opened, this button appears. Define the threshold limits on
the current frame and use the button to apply it on the whole nd2 file.

How to use the picker tool to threshold an image
1.

Select one of the cross hair

tools.

2. Left click on the image over a pixel of the image that should be considered part of the threshold/ binary
layer. All pixels with similar intensity values of the image will also be highlighted. An outline will also display
around the object(s) as well as the building solid colored threshold/ binary layer.
3. Continue to click on areas of the image that should be part of the threshold/ binary layer.
How to use the histogram to threshold an image
1. Move your mouse cursor over the histogram and hover over the vertical line labeled [L] (lower limit).Move
the vertical line left or right to set the lower limit of the threshold. Use the image and its building threshold
to provide feedback on whether the limit is set in the correct place. Accepted areas of the histogram for
the threshold are colored gray.
2. Repeat first step with the vertical line labeled [H] (higher limit)
3. You can combine the histogram with picker tools to create the thresholded image.
Threshold Adjustments
Thresholding parameters can be adjusted very precisely in the following way:
• Threshold limits of each channel can be adjusted by rewriting the values in the top-left/top-right corner of
each channel histogram.
• Threshold range of each channel (the colored stripe) can be shifted by mouse. Place the cursor in the
middle of the range (a circle appears) and drag it left or right.
• Threshold limits of each channel can be adjusted by mouse. Place the cursor on the edge of the
thresholding range and drag it left or right.
The two last behaviors can be further modified by pressing additional keys:
• Move the threshold using the right mouse button - the binary layer in the image is not updated continuously,
but is updated only once after the mouse button is released. Such operation saves some computing and
therefore is quicker.
• Hold [Shift] while moving the threshold limits - the threshold adjustment is performed on all channels together
(RGB images only).
• Hold [Ctrl] while moving the threshold limits - both the low and the high threshold limits move in opposite
directions.
Binary Operations
Three basic operations can be performed on the binary layer before it is displayed on screen. To turn the
operation on, click on the up arrow button in order to define the number of its iterations:
• [Clean] - removes small objects from binary image.
• [Smooth] - smooths the binary image contours.
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• [Fill Holes] - fills holes within binary objects.
• [Separate] - separates objects.
Restrictions
• [Size] - define size range using min/max value in the edit boxes or using the slider.
• [Circularity] - define circularity range using min/max value in the edit boxes or using the slider.
Changing Appearance of the Threshold Layer
[Overlay] button in the general controls
To change the color or transparency of the layer, right-click the
toobar in the document window. A contextual menu appears, where you can select one of the predefined
transparency levels, or run the [Colorize Binary Objects] command. This command displays the binary objects
in several different colors. The algorithm ensures that two neighboring objects are never colored by similar
colors.
See [Mathematical Morphology Basics].

6.3.2. HSI Mode
The [HSI] thresholding mode is available only if an RGB image is opened. The thresholding procedure works
the same way as in the RGB mode except that the pixel values are displayed in the HSI (Hue, Saturation,
Intensity) color space and that the [Saturation] and [Intensity] channels can be switched OFF. Therefore you
can threshold over the [H], [HS], or [HI] channels only. Switch the channel off by de-selecting the check box
in the top-left corner of the channel histogram.

6.3.3. Intensity Mode
The thresholding procedure works the same way as in the RGB mode except that it is performed on the intensity pixel values.

6.3.4. MCH Mode
The [MCH] mode is not available when working with a monochromatic (single channel) image. This mode is
dedicated to perform threshold on multichannel images, but can be applied to RGB images as well.
• If there are many channels, only one channel histogram is displayed. Switch between the channels by selecting their names from the bottom pull-down menu.
• The binary layer(s) can be displayed in two modes:
1.
2.

Each channel can create its own binary layer
One layer can be created as an intersection of all channels binaries.

6.4. Binary Layer
Working with the Binary Layer
There are the following buttons at the bottom of the right image tool bar.
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This button displays the binary layer only of the image. It can be edited by hand using the binary editor
([Binary > Binary Editor]).

The binary layer can be displayed together with the color layer using an overlay mode. Several binary
layers can be created for one color image. Manage them using the [View > Analysis Controls > Binary
Layers] control window.

This button switches to view the color image (only).
The binary layer, as a result of thresholding, can be modified by hand using the binary layer editor. It is a builtin application providing various drawing tools and morphology commands. Go for the [Binary > Binary Editor]
command or press [Tab]. New buttons appear on the tool bars:

6.4.1. Controls (horizontal tool bar)
•

Reverses the changes made to the binary image. [U]

•

Clears the binary image (fills the entire image with the "background" color). [R]

•
•

Loads the image previously saved by the [Save] button. [L]
Temporarily saves the current binary image. It can be loaded anytime before the binary editor is closed
by the [Load] button. [S]

•
•

Displays this help page.
Stores the changes and quits the editor. [ESC] or [TAB]

The other buttons of the horizontal tool bar are simplified versions of mathematical morphology functions:
•
•
•
•
•
•
•

Dilate
Erode
Close
Open
Separate Objects
Clean
Fill Holes

Please see the [Mathematical Morphology Basics] chapter.
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6.4.2. Drawing tools (vertical tool bar)
The binary image can be modified using various drawing tools. Although the way of use of some tools differs,
there are some general principles:
•

Make sure you are in the right drawing mode (drawing background

/foreground

)

• Drawing of any object which has not been completed yet can be canceled by pressing [Esc] .
• The polygon-like shapes are drawn by clicks of the left mouse button. The right button finishes the shape.
• The automatic drawing tools (threshold, auto detect) have a changeable parameter. It can be modified by
[+] and [-] keys or by mouse wheel.
• The scene can be magnified by the UP/DOWN arrows when mouse wheel serves another purposes.
• You can drag a magnified image by right mouse button.
• A line width can be set in the top tool bar.
• Hints are displayed in the second top tool bar.
Drawing Tools
•
•
•

•
•

•
•

•

•
•
•
•

Switches between the foreground and the background editing mode. [Ctrl+SPACE]
The Hand tool. Serves for moving the image when magnified. [Ctrl+W]
Bezier hollow tool. The object is defined by placing points on its perimeter. The lines connecting those
points can vary from straight lines to Bezier curves. (Use +,- keys to adjust them). To finish creation press
the right mouse button. [Ctrl+F11]
Bezier fill tool. It equals the Bezier hollow tool, but the resulting object is filled. [Ctrl+F12]
Draws a filled polygon. While holding the left mouse button down, you are in the free hand mode. When
you release it, each click defines a corner of the polygon. The polygon is enclosed and filled by pressing
the right mouse button. [F4]
Draws a polygon. It equals the Filled polygon tool, but the resulting object is not filled. [F3]
Draws a filled circle. Click to determine the center and define the perimeter holding the left mouse button
down. [F8]
Draws a circle. Click to determine the center and define the perimeter holding the left mouse button
down. [F7]
Draws a filled circle defined by three points placed on the perimeter. [Ctrl + F8]
Draws a circle defined by three points placed on the perimeter. [Ctrl + F7]
Draws a filled rectangle. [F10]
Draws a rectangle. [F9]
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•

Draws a filled movable circle/ellipse. If you grab the ellipse by the center, you can move it. If you grab
it by the border, the nearest semi-axis is being modified. When holding down either the [SHIFT] or the
[CTRL] key, both semi-axes change equally (forming a circle). [F12]

•

Draws an ellipse. [F11]

•

Drawing by hand. [F1]

•

Draws a straight line. [F2]

•
•

•

Draws a polyline. [F5]
The Auto Detect filled tool. Detect hollows using threshold techniques. Click to the image to place the
probe, the detected area is drawn. You can adjust the thresholding range by using the mouse wheel or by
pressing the +, - keys. [Ctrl+B]
Threshold tool. Click into the image to place the probe (or more of them) to define the initial color level
for thresholding. Pres +,- keys or use the mouse wheel to change the thresholding range. [J]

•

Fill an enclosed shape. [F6]

•

Area of interest. All objects outside the selected region will be erased.

•

Text tool. Displays dialog box for defining text parameters.

• [Commands] tool. The last button in the left tool bar displays the currently selected tool. You can invoke a
pop up menu and select one of the additional commands:
Commands
•

The Auto Detect hollow tool. Detect hollows using threshold techniques. Click to the image to place the
probe, the hollow is drawn.You can adjust the thresholding range by using the mouse button or by pressing
the +, - keys.

•
•
•
•
•
•
•
•
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Draws rectangularly crossed lines.
Draws a rose. Click to the image to define the center, than drag the mouse to set the length of it's arms.
Places a marker to the image. Simply click into image...
Selects binary objects.
The Connect tool. Draws a line(s) from the place you've clicked to the nearest object(s).
Displays a grid. Visible only when using magnification 400% and higher.
[Smooth] - see the [Mathematical Morphology Basics] chapter.
[Contour] - see the [Mathematical Morphology Basics] chapter.

Image Analysis

•

Inverts the binary image. Foreground becomes background and vice versa.

Binary Layer Color and Transparency
When in overlay mode:
• The [Insert] key switches between predefined overlay colors.
• [Ctrl + Up/Down] increases/decreases the binary layer transparency.
Erasing Single objects
Single binary objects can be erased in the following way:
• Run the [View > Analysis Controls > Binary Toolbar].
• Select the [Delete Object] tool from the toolbar.
• Click inside the objects to be erased.
Multiple Binary Layers
An arbitrary number of binary layers can be created within one image. Click this [Create New Binary Layer]
button in the image tool bar to add a new binary layer. The binary layer that you are currently editing can
be selected in the nearby pull-down menu. Binary layers can be managed from the [View > Analysis Controls
> Binary Layers] control window.

6.5. Regions of Interest - ROIs
In laboratory imaging experiments, users are often interested in just a part of the image. To define such an
interesting part of the image we use one or more Regions of Interest (ROIs). These regions are used later in
analysis and measurements.
Note
Do not confuse image ROIs with Camera ROI which is used to reduce the active area to just a part
of the camera sensor (CCD or CMOS). Such reduction usually results in higher frame rate. See
[Camera ROI on Live Image].

The Camera ROI Enable button

6.5.1. Creating and editing ROIs
ROIs can be created and edited using commands gathered in the ROI menu. ROIs can be also created from
binary objects, graticules (for equally spaced shapes) and from binary layers created by tracking.
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Available ROI tools

6.5.2. Types of ROI
Individual ROIs (ROI objects) are 2D objects. They can have different shape: rectangular, elliptical polygonal
or bezier. One shape can be created with one or more tools. For instance polygon ROI can be defined using
both “Draw Polygonal ROI” and “Autodetect ROI”.
In case of an ND file which has time axis (e.g. time-lapse) individual ROI objects can be defined as “Global ”
or as “Changing over time”. Global objects do not change any of their characteristics over time. Objects that
are defined as changing over time can change their position and shape in time (however objects cannot
change their shape - e.g. from ellipse to polygon). This is feature is useful for track moving or warping objects.
To track moving objects use the “Edit ROIs in Time” editor (available as a Local Option) or just change any
global ROI into changing over time from the objects' context menu and move it or change its' shape (see interactive edit) on two or more frames. Such frames are called “key-frames” (2 shows trajectories with little
boxes representing the key-frames). All frames in between key-frames are interpolated from these two keyframes. Frames before and after first and last frame respectively are taken from that first or last frame.
Therefore it is not necessary to reposition or redraw the ROI on every frame.
In case of Multi Point nd2 file there is one more option: ROI can be defined per Multi Point (which is the default).
It means that ROIs from one point are completely independent of ROIs defined on the other point (even if
they have the same number). This applies also to ROIs defined as “Changing over Time” (in case the image
has time axis too). On the other hand if the ROI is changed to a “Global” it will be shared among all points of
the Multi Point set.
Depending on the application purposes ROI objects can have different usage. NIS can handle “Background
ROIs”, “Reference ROIs”, “Stimulation ROIs” and “Standard ROIs”.
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6.5.3. Interaction with ROIs
ROIs can be manipulated anytime directly in the image window. Many of the following techniques work in ROI
editors too. Objects cannot be moved or resized when they are Locked (some analysis tools or users may
lock them to prevent accidental modification). They must be unlocked (from the ROIs' context menu) before
any manipulation. Note that the mouse cursor changes over the ROI to indicate which action will be started
after mouse button is pressed (it changes when modification keys like Alt and Ctrl are pressed).
Selection
ROI objects can be selected by clicking on an unselected object (other previously selected are unselected).
Clicking on a ROI object with Ctrl key pressed results in altering the selection state. More than one object
can be selected in this way. Double-clicking on any object results in only that object being selected. All
objects can be selected by pressing Ctrl+A or by choosing “Select All ROIs” from the menu over any ROI.
Alternatively, it is also possible to select a set of objects by dragging a rectangle around them with Ctrl
key being pressed.
Moving
Objects are moved by simply dragging them (cursor indicates that). When more objects are selected only
the one under cursor is moved by default. This can be changed by pressing the Alt key and move all
selected objects. When object is changing over time, any moving results in a new key-frame. Individual
dots representing the key-frames can be moved too.
It is possible to duplicate existing objects by Shift dragging. It works on selected objects. In case of a
key-framed object, object is duplicated with all its' key-frames unless Alt is pressed.
Resizing
Resizing a ROI is done by dragging its' contour (the cursor changes accordingly). Note that resizing hitzones extend towards outside of the object (as opposed to moving hot-zones which extend towards inside
of the object). Resizing always affects only one object (selection is not taken into account). The behavior
slightly varies depending on the object shape. By default resize does not hold aspect of the object - width
and height can be changed independently. By holding Shift key aspect is maintained (useful for circles)
and the center is not moved. Rectangle can be also rotated by using Alt key while dragging.
Exact values can be entered in “ROI Properties” dialog which is accessible from the ROI context menu.
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6.5.4. Simple ROI Editor
When creating more than one ROI, the Simple ROI editor is the tool of choice. With this tool it is possible to
make all possible shapes with different methods. All interaction techniques work here as well.

Simple ROI Editor toolbar

Note that many actions have a hot-key (P for Pointing tool, R for Rectangle, E for ellipse, L for Polygon, B for
Bezier , A for Auto detection, H for drawing holes and others) to speed up the process of interaction.

6.5.5. Edit ROIs in Time
(requires: [Tracking] ) (requires: [Local Option] )
The [Edit ROIs in time] editor simplifies editing ROIs that are changing over time. ROIs created and edited in
this tool are silently converted into changing over time in case they were global. All operations can be rolled
back by Undo/Redo.
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Edit ROIs in Time toolbar

The editor has two major tools : Draw and Detect. Both produce polygon but in the first case it is drawn
manually around a structure on the image whereas in the later it is automatically detected after one click (see
Auto-detect tool). When Draw or Detect is selected, it is possible to start drawing or detecting immediately as
indicated by cursor symbol. In case of editing an existing object, it will be hidden after this first click is made,
so the new one can be drawn unobstructed . Esc key is always available to cancel and revert to the previous
state. Other tools are for Picking, Moving and Deleting objects.
In this editor, there is always exactly one object selected. Its name and color is reported in the first combo
box. In the image here reported, there is object [1] (red) currently selected. To toggle between creation of new
objects and editing of existing ones there is a New button.
To further help with tracking the objects in time there are two automation modes which can be selected in the
After Edit combo box:
Do Nothing
maintains the current frame and selected object. User must advance manually by hotkeys or ND navigation
control as well as select objects by picking them or by means of hotkeys.
Select Next Objects
selects next object after one is edited and maintains the current frame. After all objects has been edited,
it jumps forward by the frames specified in the Skip combo box.
Jump forward
jumps forward after an object is edited and maintains that object selected.
In addition to the automation modes there are some hot-keys that improve efficiency of editing process:
• All tools have a hot-key (indicated with underscore and on the tooltip).
• Selected object can be changed with Up/Down arrows or number keys on the main keyboard (for objects
with id from 1 to 9).
• Current frame can be moved with the Left/Right keys by one frame and with PageUp/PageDown by number
of frames defined in the Skip combo. To move between key-frames it is possible to use '['/']' or ','/'.' for previous and next respectively.

6.5.6. Auto-Detect Tool
Auto-detect tool is available from ROI menu, Simple ROI editor, Edit ROIs in time editor and some other
places. It produces a Polygon ROI. Using the tool is two step process: The first click on an image structure
results in preliminary object contour, that is drawn on the screen. After that, user can further tweak the object
contour and then finish whole auto-detect by confirming with right mouse button. User can always cancel
auto-detect by pressing Esc key.
The very first click is important, because these pixels under the cursor determine intensities from which the
algorithm guesses the whole object. As a general rule it is better to choose brightest pixels in the bright objects
(fluorescence) and dimmest in the dark object. It is also good to click near the center of the object.
After the click the algorithm presents its guess of the object contour and goes into the interactive phase. In
this phase it is possible to:
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Redefine the first point
by clicking again in the image
Cancel auto-detect
by pressing Esc key
Grow or shrink the object area
(changes the intensity range of pixels making the object) by scrolling mouse wheel or pressing
PageUp/PageDown (for finer steps use Ctrl + mouse wheel)
Erode or Dilate
morphologically the object by 'E'/'D' or Down/Up keys
Open or Close
morphologically the object by 'O'/'C' keys
Morpho-separate
portions of the object by 'S' or 'P' key (if it is not possible to separate the key does nothing)

6.5.7. Using ROIs for analysis
ROIs are used mainly in Time Measurement to measure varying image intensity inside the ROIs, Automated
Measurement to measure ROIs features or number of binary objects inside each ROI , Object Count to restrict
binary objects to areas of interest only, ROI statistics to measure intensities interactively. In all these cases
ROI selection is taken into account as well as intersection options in Measurement Options.
Additionally the Time measurement interprets the ROI usage type. Background ROIs are used for offset
subtraction and Reference ROIs can be used for bleaching correction.

6.5.8. ROIs Overview
Types of ROI
Camera ROI
A rectangular ROI which restricts the live camera image. See [Camera ROI on Live Image].
Vector ROI
A ROI created by the simple ROI editor. It can be freely resized and rotated. See [ROI > Simple ROI
Editor].
Raster ROI
A ROI created by the raster ROI editor (similar to the binary layer editor - see [Binary Layer]). The raster
ROIs behave the same as the vector ROIs, but can not be resized or rotated. See [ROI > Raster ROI
Editor].
Usage of ROIs
The ROIs can be also distinguished according to their purpose. Right-click the ROI and select its purpose
from the context menu:
Standard ROI
A standard ROI restricting the area of measurement used by the automatic measurement functions.
Background ROI
The ROI specifying the background characteristics. This ROI is used as the data source by the [Image
> Background > Subtract Background Using Background ROI] command.
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Reference ROI
A special ROI used by the [View > Analysis Controls > Time measurement] control window to reduce the
influence of photo-bleaching on the resulting data.
Stimulation ROI
Confocal microscopes use this type of ROI to aim stimulation lasers.
ROIs in time
When performing time-lapse experiments, the observed objects may be moving. If a ROI has been created
over such object, you can make it move along with the object. Right-click the ROI and select one of these
options:
ROI is global
Position of a global ROI throughout different frames of the ND2 file is static
ROI changes over time
Position of a moving ROI can differ frame by frame. It is definable on an nd2 file. See [ROI in Time Moving ROIs].

6.5.8.1. ROI in Time - Moving ROIs
To define a moving ROI:
• Open or capture a time-lapse nd2 file.
• Display the first frame of the image and open the vector ROI editor by the [ROI > Simple ROI Editor] command.
• With one of the editor tools, draw the ROI around an object. Close the ROI editor.
• Right-click the ROI and select [ROI Changes Over Time] from the context menu.
• Play the image sequence and if the object of interest starts to move out of the ROI, pause the replay.
• Now it is possible to drag the ROI to the new position. If the ROI is created by the vector editor, its size and
rotation can be also modified.
• Play the sequence further and drag the ROI to a new position each time the object in the image moves.
Note
ROI positions between two user-defined frames are interpolated. If the object of interest was moving
at constant speed with a linear trajectory, then it would be sufficient to define the ROI positions only
in the first and the last frame of the image sequence.
Tips on Moving ROI
ROI Tracking
Motion characteristics of a manually defined moving ROI can be measured using the [View > Analysis
Controls > Tracking] control window. Just click the [Add Moving ROIs]
to the table of objects.

button to add the current ROIs

Automatic ROI Definition
Automatic [Tracking] features may be utilized to define moving ROIs. Already tracked objects may be
converted to moving ROIs by clicking the [Binary to ROI]
Tracking].

button. See [View > Analysis Controls >
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ROI Multiple Selection
Use the Ctrl key to select/unselect more than one ROI. When you have selected more ROIs, press and
hold the [Alt] key while dragging a single ROI. Other selected ROIs will not be moved but remain selected.
Editing ROI in time
You can edit ROIs in time using the [Edit ROIs in time] command, which is accessible from the contextual
menu of the

[Turn ROI on/off] button (in the right image toolbar).

Use provided tools to edit or create a new ROI:
Move
This tool enables to move the ROI to a different place in the image. As you place the cursor over the ROI,
color of the selected ROI is indicated near the mouse cursor (this proves very useful when you have
defined many ROIs, or they are overlapping). Simply drag and drop the ROI to another position.
Pick
Use this tool to select directly in the image which ROI you want to edit.
Draw
Use this tool to draw a freehand curve which defines new region of interest. Press the right mouse button
to close the curve and finish the definition.
Detect
Enables to redetect ROI or to detect a new ROI (when the [New] button is pressed, or New item is selected
from the pull down menu).
New
Press this button to create a new ROI. According to which detection tool is selected, you can either start
drawing a new ROI, or click inside the image to let the application detect the ROI automatically.
ROI picker
Select which ROI you want to edit from the pull down menu.
After Edit
Specify which action is taken after a ROI has been edited. The [Jump Forward] option displays another
time frame according to set number of frames in the Skip pull down menu.
Skip
Choose how many frames are skipped after an object is edited (and the [Jump Forward] option is selected).
Skip 1 frame just moves to the nearest next frame.
Delete
Press this button to delete selected ROI.
Undo/Redo
Moves back and forth through the history of changes.
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Help
Displays help file.
Finish
Press this button to finish definition and close the dialog.

6.6. Creating Reports
Report Generator enables the user to create customized reports containing images, measured data, user
texts, graphics, or database entries. PDF files can be created directly from NIS-Elements AR. When you invoke
the [File > Report > New Blank Report] command, a [Report Generator] window appears.
Note
Use [Adobe Reader] to display PDF reports created by NIS-Elements. Correct performance of other
reader software products can not be guaranteed.

It provides the following tools:
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•

Draw line...

•

Draw rectangle...

•

Draw ellipse...

•

Draw Arrow...

•

Insert text field...

•

Insert image from file...

•

Insert Table

•

Insert graph

•

Insert bar code

•

Align - aligns selected objects to the position indicated on the button by the line

•

Center - aligns the selected objects to center

•
•

Distribute - distributes the objects uniformly along the specified direction
Determines whether to apply the align commands relatively to the whole page or the selected objects
only.

Context Menu Commands
Once you insert an object, its appearance, behavior, and position can be changed via the context menu which
appears on right-click:
• If there are more than one objects selected, the [Group] command makes them to behave as a single object.
• The [Align or Distribute] commands enable moving objects within the page or align them with another object(s).
• The [Resize object] commands enables to resize two objects to the same size.
• The [Bring to front] command changes the order of overlapping objects and brings the current object to
front.
• The [Send to back] command moves the object to the bottom layer.
• The [Lock] command locks the object disabling any further changes to it until it is unlocked.
• The [Properties] command opens a window where object properties such as color, background color, border
size and color, object size, font, aspect ratio, alignment, and shape can be adjusted.
Insert images, text fields and other objects to the report.
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6.6.1. Working with Report Objects
When you double-click any of the report objects, a window appears where the properties can be adjusted.
Some properties are common to all types of objects, and some are special.
Common Properties
• The precise position can be determined by defining the XY coordinates of the top-left corner of the object.
• Line and fill colors can be selected.
• Line widths can be adjusted within the range of 0,25 to 6 pts.
• Precise width and height of the objects can be adjusted.
• Rotation of some objects can be adjusted.
Special Object Properties
Ellipse
Minor and major axes lengths can be modified.
Arrow
The arrow tip shape and size can be modified.
Text Box
• Format of the text can be adjusted like in a standard text editor.
• The current date and time can be inserted from a pull-down menu.
Image
• A new picture can be loaded to the image frame via the [Load Picture] button.
• The current image scale is displayed in the properties window. It shows the [current scale/original image
dimensions] ratio (the image must be calibrated to use this feature).
• A scale bar can be displayed below the image. The position and width of the scale bar can be defined.
Table
• Inner and outer borders can be hidden or displayed.
• Number of rows/columns can be modified.
Graph
• The range of displayed values can be limited by defining the min/max values.
• Histogram labels can be edited.
Aligning Objects
You can align two objects to the same horizontal or vertical level.
• Select more objects (e.g. by holding down [CTRL] and clicking with the left mouse button).
• Right-click one of the selected objects and select the [Align or Distribute > Align ...] command from the
context menu.
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• The objects will be aligned as indicated on the command icon.
• If the [Relative to Page] option is turned [ON], the objects will be aligned to the edges or the center of the
page.
Objects of similar size can be distributed uniformly in the horizontal/vertical direction.
• Select three or more objects.
• Right click one of the objects and select the [Align or Distribute > Distribute...] command from the context
menu.
• Distances between the objects will be adjusted to equal.
• If the [Relative to Page] option is turned [ON], the outer objects will be moved to the edges of the page.
Sizes of objects can be unified too.
• Select two or more objects.
• Right-click the “master” object to the size of which you want to resize the other objects.
• Select one of the [Resize Objects] sub-menu commands.
Dynamic Data
Results of automatic-interactive measurement, graphs, or the current image can be inserted to reports.
• Insert an object which can contain dynamic data (text, picture, table, or graph).
• Right-click the object and select [Insert Dynamic Data/Insert Dynamic Picture] from the context menu.
• A window appears.
• Select one of the available sources, and click [Next] .
• Finish the source definition and click [OK] . The data appear on the report page.
List of Available Dynamic Data Sources:
• [Data inserted by user] (available for: image, text, table ) - the system will ask you to type a text or browse
for an image to insert during the report creation. When creating a dynamic object of this type, a query text
which will be used to prompt you for the data can be defined.
• [System data] (available for: text, table ) - enables you to insert some general data such as date, the name
of the user account currently logged in, the page number, or the page count.
• [Macro] (available for: text, table ) - enables you to insert expressions, values, or results of a macro.
• [Measurement] (available for: text, table, graph ) - enables you to insert results of automatic/interactive
measurement.
• [Database] (available for: image, text, table ) - this data source is displayed only when creating a database
report template (see below). It enables you to insert a link to any of the database records.
The real purpose of the dynamic data turns up when creating reports using report templates.

106

Image Analysis

6.6.2. Working with Report Templates
A report template is a layout defining the appearance of future reports, which is ready to be filled with data.
The data can be inserted by the user “on demand” or automatically (dynamic data).
To Create a Report Template
• Run the [File > Report > New Blank Report] command. An empty report appears.
• In the Report Generator, select [File > Change to Template].
• Edit the report template in the same way as a common report.
• Insert the dynamic data where it is appropriate - measurement results to text boxes or tables, the current
image to the image field, etc.).
• Save the report template (*.rtt) via the [File > Save] command.
To Create a Report from Template
• If the template is opened inside the Report Generator, run the [File > Create Report] command. Otherwise,
use the [File > Report > New Report from Template] command inside the main application window to open
a template from harddisk.
• A report opens and the dynamic data is inserted automatically.
• Save the report, print it, or export the page(s) to PDF using the commands from the [File] menu.

6.6.3. Creating Reports from Database
Pictures of a database together with the associated table data, or common images with the associated [Image
Info] can be exported straight to a report.
• Switch NIS-Elements AR to [Organizer] by the [View > Organizer Layout] command.
• Select one or more images. These images will be inserted to the report.
•

Click the [Report]

button on the main tool bar. The following window appears:
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• In the [Columns] section, you can select fields, which will be included in the report. If you are exporting images
from a database, the database table fields will be listed. If you are exporting images from a directory, image
description items will appear.
• The [Template] portion of the dialog specifies the layout details. If you select the [Standard] template, images
will be organized in rows and columns. It is possible to set the number of columns and rows. If you select
the [Custom] report template, a user report template (*.rtt) can be opened and used for the report creation.
If such report does not exist yet, you can create it using the [Create New] button.
If You Pressed the [Create New] Button
• A wizard appears. Select number of columns and rows of the new report template. Click [Next].
• Select the paper size, page orientation, and define margins. Click [OK] .
• An untitled report template opens containing a grid of images spaced according to the [columns/rows] settings.
• Edit the top-left cell of the image grid. You can change the text/image boxes position, size, and mapping.
During report creation, all the other cells of the grid will be filled automatically according to the settings of
the first one.
• A custom header or automatic page numbering can be added to the report.

6.7. Creating Movies
Movies is one of the possible ways to present data captured using NIS-Elements AR. The following functionality is available:
• A real-time movie of a time-lapse process can be captured.
• An ND2 file can be converted to a movie.
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• A 3D model or a surface view of an object can be set in motion and make a presentation movie.
Movies are saved as an [AVI] which can be played back by any standard video player so you do not need
NIS-Elements AR to view them.

6.7.1. Capturing AVI Movie
• Display the AVI Acquisition control window by the [Acquire > AVI Acquisition] command.
• Adjust the advanced settings, especially define the file name and the destination folder.
• Click the [Record] button. The live image appears and recording starts according to the settings.
• Stop recording by the [Stop] button, or wait until the time defined in the [Duration] field passes.
• When stopped, the AVI file remains opened in a new image window.
Settings
Press the [Advanced] button to view the whole control window and set the following options:

Live
Choose the format of the camera. The Live-Fast or Capture-Quality mode settings will be used while
capturing the AVI movie.
Rate
The number of frames per second of the movie can be defined. Possible values range from 1 to 50 fps.
There is also the [Max Fps] option. When selected, the system captures every frame sent from a camera.
If the frame rate is beyond hardware capabilities of your system, some frames will be omitted.
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Duration
Several predefined lengths of the movie may be selected (60 min, 10 min, 1 min, 10 s) or the [Infinite]
option is available. When selected, the movie will be captured until the [Stop] button is pressed or the
hard drive is filled to capacity.
File - the path and the name
Define the path to a directory and the file name of the AVI file. If you capture more then one movie without
changing the file name setting, the other files will be numbered automatically.
File - Codec
It is common to encode (compress) movies in order to save some disk capacity. This can be done using
various types of codecs. Press the [Open] button on the right and a window appears. Select one of the
codecs available in the system or use the [Default] option. Remember that the codec you choose will be
required for the AVI playback as well (when playing the video on other computers).
Note
Video codec is a software tool which can code and decode video files. We recommend to use
one of the following codecs:
Cinepack
Provides maximum compatibility and small files.
Intel Indeo
Provides the best quality/compression rate.
Microsoft YUV
A non-compression (maximum-quality) codec.
Size
The size is determined by the resolution of the connected camera, but can be adjusted by the following
options:
[Original], [1/2 Original], [1/4 Original]
Sizes counted from the applied camera resolution
[NTSC TV], [PAL TV]
Standard TV resolutions
Free Size
an arbitrary [Width] and [Height] in pixels may be defined.
No matter what size is selected, the video always displays the whole scene. If the defined size has different
aspect ratio than the live image, the empty space is filled with black.
Maintain aspect ratio of
If the [Free Size] option is selected, the aspect ratio may be defined. One of the width and height dimensions are then counted automatically.

6.7.2. Converting ND2 to AVI
You can easily create an AVI movie from an nd2 file. Run the [File > Save As] command and instead of saving
the file as an ND2, simply select the AVI format in the [Save As Type] pull-down menu. The [Save As] window
expands as follows:
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Adjust the AVI file settings and press [Save] to finish. Please see the [File > Save As] command description
for more details.

6.7.3. Creating QuickTime movie
You can easily create a QuickTime movie from an ND document. Run the [File > Save As] command and
select QuickTime Movie File Format in the [Save As Type] pull-down menu. The [Save As] window expands.
Adjust the *.mov file settings, used compression and press [Save] to finish.
Note
QuickTime Player must be installed on your PC.
Warning
You cannot create QuickTime movie from an ND document that contains Multi-point dimension.

6.7.4. Movie Maker
(requires: [Local Option] )
Models displayed in [3D Volume View] or [EDF 3D Surface View] (requires: [Extended Depth of Focus] )
can become actors of your movies once the NIS-Elements AR movie-maker is started. The Movie Maker
button located on the image tool bar (Volume View or Surface
control window appears after you press the
View must be active). The user is supposed to create a set of key-frames. The rest of the movie will be created
by interpolation between these key frames. This gives the user absolute freedom in how the movie will look
like.
Movie Maker Controls
When you start the movie maker, the following bar appears at the bottom of the image view.

1. The [Clapper] button. By this button, the director's mode can be turned ON/OFF. See Directors Mode.
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2. Time line. By clicking to the time line you can browse the movie frames. When a key frame is added, a
bold line appears in the time line to indicate its position.
3. [First Frame], [Play], [Last Frame] buttons.
4. [Settings] - by this button, you can define the movie length and the frame rate.
5. [Create Movie]
6. The key frame buttons. The existing key frames may be browsed by pressing the [Previous/Next Key
Frame] buttons. The [Add/Update Key Frame] button inserts a key frame to the current position on the time
line.
7. [Presets] - a predefined rotation can be loaded. When you press the button and select the rotation type,
the existing key frames settings will be overwritten.
8. [Import/Export Key Frames] - this enables you to save and load the key frame settings. A file with the
[*.KEY] extension will be created during the export.
How to Create a Movie
•

Run the Movie Maker by the

button.

• Adjust the movie settings by the [Settings] button a window appears where the movie duration and frame
rate can be defined.
• You can use one of the predefined presets or import some previously defined key frames by the [Export/Import] button.
• Either enable or disable the Director's mode by the clapper button. See Directors Mode.
• Go to the beginning of the time line and define the initial zoom, position, rotation or component appearance
of the object. This step is not necessary, but very much recommended. Press the [Add/Update key frame]
button to fix the initial appearance.
• Browse the time line, modify the object position each time, and set key frames by clicking the [Add/Update
key frame] button. Press the [Play Movie] button for a preview.
• When all the key frames are properly set, press the [Create Movie] button. The movie is created and the
AVI file will open in a new image window.
• Save the new file by the standard [File > Save As] command.
Directors Mode
In the directors mode it is not needed to press the [Add key frame] button every time the position of the object
is changed. The director's mode detects all changes made to the object position and adds a key frame to the
time line whenever such change is detected. A typical work-flow would look like this:
• Turn ON the directors mode by the [Clapper] button. The time line gets highlighted with red color.
• Click to the time line where a certain position of the object shall occur.
• Move the object by mouse or adjust it in some way (zoom, crop, etc.) - at this moment, the key frame will
be added to the time line automatically.
• Click to the time line where another position shall occur, and so on...
The director's mode shall be used when you know precisely how the movie shall look.
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Special Options
A contextual menu appears whenever you right-click on any key frame or between two key frames (a segment)
within the time line.
Set key frame time
Sets the selected key frame position - moves the key frame to this position.
Set as new start of the movie
Sets the selected key frame as the first frame of the movie and moves all other key frames proportionally.
Key frames prior to the selected one will be deleted.
Set as new end of the movie
Sets the selected key frame as a new end of the movie and moves all other key frames proportionally.
Key frames past the selected one will be deleted.
Copy/Paste key frame
Enables to copy and paste key frames.
Delete key frame
Deletes the selected key frame.
Delete all key frames
Deletes all defined key frames.
Set time segment duration
Sets the segment duration. Positions of all other key frames will be moved proportionally.
Hold/Linear/Spline
Select the type of interpolation to be used between two key frames. Set [Spline] for smooth changes
(motion, lightness etc.)

Interpolation Types

Ease in/out
Easing defines the interpolation rate between two key frames. No easing means constant rate of interpolation. Use the [Ease in] option for the first time segment to increase slowly the rate of change. On the
contrary, the [Ease out] option serves the best at the end of the movie to make the motion slowly stop.
Of course, you can get the benefit of combining them.
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Presets
Simple and fast way how to make a movie is to use any of the predefined presets.
360º turn around X/Y/Z axis
Makes movie of Volume view rotating around selected axis.
Build-up in Z direction
Makes movie of appearing Volume view which starts from the bottom up.
Build-up in Z direction (reversed)
Makes movie of appearing Volume view which starts from the top down.
Time sequence
Makes movie of Volume view within the Time loop.
Combine presets
Different presets can also be combined together. Simply select items from the list of all available presets.
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7. Measurement
7.1. Measurement
7.1.1. Calibration
Calibration of the image is of crucial importance to measurement. A distance will be assigned to one pixel so
that correct and realistic measurements can be performed and objects of different images could be compared
to each other. A correct calibration has to be made before you begin to measure.

7.1.2. Rough Measurement
Quick and approximate measurements can be performed utilizing graticules. They behave like adjustable
floating rulers. User can simply align a graticule with the measured object and read the distance value (e.g.
the diameter). To activate the graticule, press the [Graticules] button.
Select Graticule Type
The type of the graticule ruler is indicated by a picture on the [Graticules] button placed on the right image
tool bar. To change the graticule type, click on the graticules button with the right mouse button and select
the appropriate item from the context menu:
•
•
•
•
•
•
•
•

Rectangular Grid
Circle
Simple Circle
Cross
Industrial Cross
Simple Cross
Vertical Ruler
Horizontal Ruler

Define Graticule Properties
Right click the [Graticules] button and select the [Graticules properties] command from the pull-down menu.
A window appears where display parameters (shape, color, line width, density of lines) of all graticules can
be adjusted.
Graticules Density
The density value - the closest distance between two line intersections of the graticule - can be set, or
you can let NIS-Elements AR adjust it automatically according to the current zoom factor. The units selection depends on the image calibration (calibrated/uncalibrated).
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Note
graticule. The distance defined by [Density] is divided into smaller
Concerning the [Cross]
sections automatically. However, for odd density values greater than 10, the markings remain
hidden because it is not possible to display them accurately.
Measure the Image
The graticule measurement provides the following options:
• The graticule can be moved by mouse arbitrary.
• The graticule position can be reset by using the [Move Graticules to Center] command from the context
menu.
• A binary layer can be created from the current graticule using the [Copy Graticules to Binary] command.
• A [Graticule Mask] can be created from the current binary layer using the [Copy/Add Binary to Graticule
Mask] command.
• A [Graticule Mask] can be stored/loaded to/from an external file via the [Save Graticule Mask As] and [Open
Graticule Mask] commands.
• A new image containing graticules can be created by the [Edit > Create Full View Snapshot (8bit RGB)]
command.
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7.1.3. Manual Measurement

Length, area, angles, taxonomy, counts, circle radius, and ellipse semiaxes can be measured manually over
an image.The results are being recorded to a simple statistics table, which can be exported to a file or clipboard.
Also, the data can be presented as a graph.
• Run the [View > Analysis Controls > Annotations and Measurements] command. The manual measurement
control window appears.
• Select a tool corresponding to the feature you are going to measure. There are several tools for measuring
each feature.
• Measure the objects in the image using mouse.
• Select where to export results in the [Export] pull-down menu.
• Export the results using the [Export] button.
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Example Procedure
Measurement of the image of a grain:

1)

Select the [Horizontal parallel lines]

tool.

2)

Place the first line on the top edge of the crystal by clicking into the image. The position of the line can
be adjusted while you hold the left mouse button down. After you release it, the line is positioned.

3)

Repeat this to place the second line on the bottom edge of the crystal.

4)

When finished, an arrow is drawn between the lines, and the result of the measurement is attached.
A record with the measurement type and the measured value is added to the results table.

Working with the Measurement and Annotation Objects
There are two types of vector objects which can be placed over the image: annotation objects and measurement
objects.

This button of the right image tool bar turns the visibility of annotation layer ON/OFF. Right-clicking the
button displays a context menu with the following options:
• [Clear All Objects] will delete annotation and measurement objects.
• [Clear Annotation Objects] will delete all annotation objects.
• [Clear Measurement Objects] will delete all measurement objects.
• [Select Annotation Objects] will select all objects that are not the measurement ones.
• [Select Measurement Objects] will select all measurement objects.
• [Select All Objects] and [Deselect] will select/deselect all annotation and measurement objects.
Visibility of annotation/measurement objects
In an ND document that contains time dimension, you can set visibility of any annotation object by the
following rules:
• object is visible globally means in all frames in all dimensions - select the option [Object is always visible]
• object is visible in all T, Z dimensions, but only in current multipoint - select the option [Object is always
visible] and check the [Object belong only to Current Multi Point] option
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• object is visible only in selected time frames in all multipoints - select the option [Object is visible in
range]
• object is visible only in selected time frames in current multipoint - select the option [Object is visible
in range] and check the [Object belong only to Current Multi Point] option
Select one of these rules in the context menu that appears when you click with right mouse button on an
annotation object in the ND document. Detailed definition of object visibility can be done using commands
in the [Visibility in Time] sub-menu.

7.1.4. Automated Measurement
Automated measurement is the most powerful of image analysis features. In combination with user macros,
NIS-Elements AR can become a semi- or fully-automatic image analysis tool.There are several key procedures
which a proper automated measurement should involve:
• Optical system calibration (see the [Optical Configurations] chapter)
• Image acquisition. (see the [4 Capturing] chapter)
• Defining threshold, creating the binary layer (see the [Thresholding] chapter)
• Performing the automated measurement
• Results presentation
Image Layers Involved in Measurement
The the binary layer and also the color image can get involved in the automated measurement:
• [Binary layer] - is typically used for shape and size measurements (area, perimeter, surface fraction).
• [Color layer] - intensity or hue measurements are carried out on this layer. The area covered with the binary
layer is used as the source data.
Object/Field Measurement
NIS-Elements AR distinguishes two types of automated measurements: object and field.
Object Measurement
Groups of neighbouring pixels of the binary layer are called objects. Results of the object measurement
are usually the object data such as Length, Area, CentreX/Y (the X,Y position of the central pixel of an
object), etc.
Field Measurement
Field measurements produce information regarding the whole measurement area (measurement frame,
ROI). Such information can be Area Fraction, Mean Brightness, Density Variation, etc.
Please see the complete list of measurement features in the [Measurement Features] chapter.
Restricting the Area of Measurement
The area of measurement can be restricted by the measurement frame or by a user defined region of interest
(ROI).
Region of Interest - ROI
ROI is a user defined area of the image. Whenever the ROI is displayed (by the [View > Layers > ROI]
command), it is also applied to restrict the area of measurement.
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Measurement Frame
The measurement frame is a re-sizable rectangular frame which serves for bounding the area accepted
for measurement. Turn the measurement frame ON via the [Measure > Use Measurement Frame] command.
Binary objects touching edges of ROI or the measurement frame can be treated differently (excluded
from the measurement or included).This behavior can be specified within the [Measure > Options] window.
Statistics and Data Presentation
NIS-Elements AR calculates basic statistics - mean value, standard deviation and distribution of all measured
features. The features to be measured can be selected in the [Measure > Object Features] and the [Measure
> Field and ROI Features] windows. Results of all automated measurements are presented and can be exported
from the [View > Analysis Controls > Automated Measurement Results] control window.

7.2. Measurement Features
The following list describes all the features that can be measured within NIS-Elements AR Measurements.
Suitable type of measurement (object, field, manual) and the required image layer (binary, color/binary) are
included in the description. See also [Measurement].
AcqTime
Calling the Grab Sequence command, the AcqTime is set to zero at the beginning. Then, NIS-Elements
AR assigns the AcqTime to every newly grabbed image file header, which denotes time elapsed from
the beginning of the grabbing. If the Grab Sequence command is not called, than the AcqTime is the time
elapsed since the start of NIS-Elements AR .
Measurement Type: object, field
Image Type: binary
Area
Area is a principal size criterion. In a non-calibrated system, it expresses the number of pixels; in a calibrated one, it expresses the real area.
Measurement Type: object, field, manual
Image Type: binary

AreaFraction
AreaFraction is the ratio of the segmented image area and the MeasuredArea. It has a strong stereological interpretation: in the case of isotropic uniform random sections it is equal to the volume fraction.
AreaFraction = Area/MeasuredArea
Measurement Type: field
Image Type: binary
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Blue
Blue value is the mean of blue component pixel values. It is the usual statistical mean of intensity values
of the blue component.
Measurement Type: manual
Image Type: color
BoundsLeft, BoundsRight, BoundsTop, BoundsBottom
These are distances (X or Y coordinates) of the left, right, top, and bottom edge of the object bounding
rectangle. The units of calibration are used if the image is calibrated. Otherwise, the coordinate value is
in pixels.
Measurement Type: object
Image Type: binary

BoundsAbsLeft, BoundsAbsRight, BoundsAbsTop, BoundsAbsBottom
These are absolute distances (X or Y coordinates) of the left, right, top, and bottom edge of the object
bounding rectangle within a motorized stage range. This feature can be measured only when a motorized
stage is connected.
Measurement Type: object
Image Type: binary
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BoundsPxLeft, BoundsPxRight, BoundsPxTop, BoundsPxBottom
These are distances (X or Y coordinates) of the left, right, top, and bottom edge of the object bounding
rectangle. Unlike the BoundsLeft,... distance, this value is always in pixels.
Measurement Type: object
Image Type: binary
BrightVariation
It is the usual standard deviation of brightness values.
Measurement Type: object, field
Image Type: color/binary
CentreX
CentreX is the x co-ordinate of the center of gravity. The units of calibration are used if the image is calibrated. Otherwise, the coordinate value is in pixels.
Measurement Type: object
Image Type: binary
CentreY
CentreY is the y co-ordinate of the center of gravity. The units of calibration are used if the image is calibrated. Otherwise, the coordinate value is in pixels.
Measurement Type: object
Image Type: binary
CentreXabs
CentreXabs is the absolute x co-ordinate of the center of gravity within a motorized stage range. This
feature can be measured only when a motorized stage is connected.
Measurement Type: object
Image Type: binary
CentreYabs
CentreXabs is the absolute y co-ordinate of the center of gravity within a motorized stage range. This
feature can be measured only when a motorized stage is connected.
Measurement Type: object
Image Type: binary
CentreXpx
CentreXpx is the x co-ordinate of the center of gravity. Unlike the CentreX coordinate, this value is always
in pixels.
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Measurement Type: object
Image Type: binary
CentreYpx
CentreYpx is the y co-ordinate of the center of gravity. Unlike the CentreY coordinate, this value is always
in pixels.
Measurement Type: object
Image Type: binary
Circularity
Circularity equals to 1 only for circles; all other shapes are characterized by circularity smaller than 1. It
is a derived shape measure, calculated from the area and perimeter. This feature is useful for examining
shape characteristics.
Circularity = 4* π *Area/Perimeter

2

Measurement Type: object
Image Type: binary
Class
NIS-Elements AR recognizes 12 classes (1-12). If you have selected class feature (function Object
Features or Field Features), system automatically asks you to specify the class via dialog box. In field or
scan objects measurements, the application asks for a class before measurement is performed on the
current image. In single object measurement, NIS-Elements AR asks for a class for every measured
object. In the case you want to pass by, there is a possibility to run the SetClass function.
Measurement Type: object, field, manual
Image Type: binary
Convexity
Indicates convexity of the object edges.
Convexity = Area / Convex Hull Area
Measurement Type: object
Image Type: binary
DensityVariation
DensityVariation is derived from density values. It is a usual standard deviation of density values.
Measurement Type: object, field
Image Type: color/binary
EdfSurface
EdfSurface is based on 3D model. It determines the surface area of an 3D object.
Measurement Type: object, field
Image Type: binary, EDF
EdfRoughness
EdfRoughness is based on 3D model. It indicates how much the 3D object is rough.
EdfRoughness = EdfSurface/Area
Measurement Type: object, field
Image Type: binary, EDF
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Elongation
Elongation is determined as a ratio of MaxFeret and MinFeret features. This feature is useful for shape
characteristics.
Elongation = MaxFeret/MinFeret
Measurement Type: object
Image Type: binary
EqDiameter
The equivalent diameter is a size feature derived from the area. It determines the diameter of a circle
with the same area as the measured object:
Eqdia = sqrt(4*Area/ π )
Measurement Type: object, manual
Image Type: binary

ExPurity
This feature specifies the amount of white in the measured color, if the measured color can be composed
of white and a pure spectral color.
Measurement Type: object, field, manual
Image Type: color
FillArea
In case an object does not contain holes then the FillArea is equivalent to the Area. If an object contains
holes, FillArea remains the same while Area is reduced by the area of the holes.
Measurement Type: object
Image Type: binary

FillRatio
FillRatio is the ratio of Area and FillArea:
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FillRatio = Area/FillArea
If an object does not contain holes the FillRatio is equal 1. If an object contains holes, FillRatio is less
than 1. This feature can distinguish objects with and without holes.
Measurement Type: object
Image Type: binary
IntensityVariation
IntensityVariation is derived from an intensity histogram. It is an usual standard deviation of intensity
values. This feature describes the inner structure of an object or a field.
Measurement Type: object, field
Image Type: color
Green
Green value is the mean of green component pixel values. It is the usual statistical mean of intensity
values of green component.
Measurement Type: manual
Image Type: color
HueTypical
HueTypical is the hue value with maximum frequency in a hue value histogram. This feature describes
the most frequent hue (color) in an object or field.
Measurement Type: object, field
Image Type: color/binary
HueVariation
HueVariation is the usual standard deviation of hue values. This feature describes hue (color) distribution
of inner structure of an object or field.
Measurement Type: object, field
Image Type: color/binary
SumBrightness
SumBrightness is defined as the sum of brightness in every pixel of the object.
Measurement Type: object, manual
Image Type: color/gray
SumDensity
SumDensity is the sum of individual optical densities (O.D.) of each pixel in the area being measured.
This feature describes, for instance, the amount of a substance in biological sections. Optical density is
evaluated according to the following formula:
O.D. = -log((PixelIntensityValue + 0.5)/62.5)
Measurement Type: object, field, manual
Image Type: color/binary
SumIntensity
Sum Intensity is defined as the sum of intensity in every pixel of the object.
Measurement Type: object
Image Type: color/gray
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Length
Length is a derived feature appropriate for elongated or thin structures. As based on the rod model, it is
useful for calculating length of medial axis of thin rods.
2

Length = (Perimeter + sqrt(Perimeter - 16*Area))/4
Measurement Type: object, manual
Image Type: binary

LineLength
Line length is defined as the length of the object with elongated shape.
Measurement Type: object
Image Type: color/gray
Luminance
Luminance is defined as a radiant power weighted by a spectral sensitivity that has characteristics of
human vision.
Measurement Type: object, field, manual
Image Type: color
MaxFeret
The MaxFeret is the maximal value of the set of Feret's diameters. Generally (for convex objects), Feret's
diameter at angle α equals the projected length of object at angle α , α (0,180); NIS-Elements AR calculates
Feret's diameter for α =0, 10, 20, 30, ..., 180.
Measurement Type: object, manual
Image Type: binary
MaxFeret90
The MaxFeret90 is a length projected across the MaxFeret diameter.
Measurement Type: object, manual
Image Type: binary
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MaxIntensity
MaxIntensity value is derived from the intensity histogram. It is the maximal of intensity pixel values.
Measurement Type: manual
Image Type: color/gray
MeanBlue
MeanBlue value is the mean of blue component pixel values. It is the usual statistical mean of intensity
values of blue component.
Measurement Type: object, field, manual
Image Type: color/binary
MeanBrightness
MeanBrightness value is the usual statistical mean of brightness values of pixels.
Measurement Type: object, field, manual
Image Type: color/binary
MeanDensity
MeanDensity value is the usual statistical mean of density values of pixels.
Measurement Type: object, field, manual
Image Type: color/binary
MeanIntensity
MeanIntensity value is derived from the intensity histogram. It is the usual statistical mean of intensity
values of pixels.
Measurement Type: object, field, manual
Image Type: color/binary
MeanGreen
MeanGreen value is the mean of green component pixel values. It is the usual statistical mean of intensity
values of green component.
Measurement Type: object, field, manual
Image Type: color/binary
MeanChord
MeanChord is the mean value of secants in the 0, 45, 90 and 135 degrees directions. It is a derived
feature and is calculated from the Area and mean projection according to the following formula.
MeanChord = 4*Area/(Pr0 +Pr45 +Pr90 +Pr135 )
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Measurement Type: object, field
Image Type: binary
MeanRed
MeanRed value is the mean of Red component pixel values. It is the usual statistical mean of intensity
values of red component.
Measurement Type: object, field, manual
Image Type: color/binary
MeanSaturation
MeanSaturation is a statistical mean of saturation values of pixels.
Measurement Type: object, field
Image Type: color/binary
MeasuredArea
MeasuredArea value is the area of the measurement frame or of a mask within the measurement frame,
if the mask status is on.
Measurement Type: object, field
Image Type: binary
MinFeret
The MinFeret value is the minimal value of the set of Feret's diameters. Generally (for convex objects),
Feret's diameter at angle α equals the projected length of object at angle α , α (0,180); NIS-Elements
AR calculates Feret"s diameter for α =0,10,20, 30, ..., 180.
Measurement Type: object, manual
Image Type: binary
MinIntensity
MinIntensity value is derived from the intensity histogram. It is the minimum of intensity values of pixels.
Measurement Type: manual
Image Type: color/gray
NumberObjects
NumberObjects value returns the number of objects in the measurement frame. Exclusion rules for
counting objects are taken into account.
Measurement Type: field
Image Type: binary
Orientation
Orientation is the angle at which Feret's diameters have their maximum. The diameters are calculated
with 5 degrees angle increment.
Measurement Type: object
Image Type: binary
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Perimeter
Perimeter is the total boundary measure. It includes both the outer and inner boundary (if there are holes
inside an object). The perimeter is calculated from four projections in the directions 0, 45, 90 and 135
degrees using Crofton's formula
Perimeter = π *(Pr0 +Pr45 +Pr90 +Pr135 )/4
Measurement Type: object, field, manual
Image Type: binary

Red
Red is the mean of red component pixel values. It is the usual statistical mean of intensity values of red
component.
Measurement Type: manual
Image Type: color
Roughness
This feature indicates how much the object is rough. “1” means the object roughness is minimal (the object
is circular).
Roughness = Convex hull perimeter / Perimeter
Measurement Type: object, manual
Image Type: binary

129

RoughnessInf
This feature indicates how much the object is rough. “1” means the object roughness is minimal (the object
is circular)
RoughnessInf = 1 / Roughness
Measurement Type: object, manual
Image Type: binary
ShapeFactor
This parameter is to define whether the object is rough or not.
Shape factor = 4 π (area)/(Convex hull perimeter)

2

Measurement Type: object, manual
Image Type: binary

StartX
StartX is the x co-ordinate of a pixel on the object boundary. When you scan the image from the origin
as indicated (left->right), the first pixel of the object you hit is the one with StartX and StartY coordinates.
Measurement Type: object
Image Type: binary

130

Measurement

StartY
StartY is the y co-ordinate of a pixel on the object boundary.
Measurement Type: object
Image Type: binary
StgPosX
StgPosX feature is the x co-ordinate of the absolute position of the measured field. It is available only for
systems equipped with a stage.
Measurement Type: object, field
Image Type: binary

StgPosY
StgPosY feature is the y co-ordinate of the absolute position of the measured field. It is available only for
systems equipped with a stage.
Measurement Type: object, field
Image Type: binary
SurfVolumeRatio
SurfVolumeRatio is a feature with a strong stereological interpretation: if you measure on fields that are
sampled systematically and independently of the content of the sections, then the feature is an unbiased
estimator of the surface area of objects (inner structure) per volume of the whole sample.
SurfVolumeRatio = (4/ π )*Perimeter/MeasuredArea
Measurement Type: field
Image Type: binary
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Time
Time assigns the time to a field (object) after a measurement has been performed. See the SetReferenceTime function help.
Measurement Type: object, field
Image Type: color/binary
VolumeEqCylinder
This parameter is based on the rod model. Length is interpreted as height and Width as the base diameter
of a cylinder. Bases are considered to be spherical.
2

3

VolumeEqCylinder = ( π d )*(l-d)/4 + π d /6,
where l=max(MaxFeret, Length), d=min(MinFeret, Width).
Measurement Type: object
Image Type: binary

VolumeEqSphere
Supposing a profile was created as an intersection of a ball and a section that contains the center of the
ball. VolumeEqSphere is the volume of the ball.
3

VolumeEqSphere = π *Eqdia /6
Measurement Type: object
Image Type: binary

WaveLen
Dominant wavelength. This feature is defined as a wavelength of the pure spectral color that is, together
with white, the measured color composed of. The color in the purple must be composed of more than
one pure spectral colors therefore they have no dominant wavelength.
Measurement Type: object, field, manual
Image Type: color
Width
Width is a derived feature appropriate for elongated or thin structures. It is based on the rod model and
is calculated according to the following formula:
Width = Area/Length
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Measurement Type: object
Image Type: binary

7.3. Mathematical Morphology Basics
The binary image as a result of thresholding often needs to be modified before a measurement is performed.
Edges of the objects can be smoothed, holes in the objects filled etc. by using the mathematical morphology
commands.
Note
“Image Analysis and Mathematical Morphology” by J. Serra (Academic Press, London, 1982) was
used as a reference publication for the following overview.
The basic processes of mathematical morphology are: erosion, dilation, open, close and homotopic transformations.
Erosion
After performing erosion, the objects shrink. Marginal pixels of the objects are subtracted. If an object or
a narrow shape is thinner than the border to be subtracted, they disappear from the image.
Dilation
After performing dilation, the objects enlarge. Pixels are added around the objects. If the distance between
two objects is shorter than twice the thickness of the border to be added, these objects become merge
together. If a hole is smaller than twice the thickness of the border, it disappears from the image.
Open
Open is erosion followed by dilation so the size of the objects is not significantly affected. Contours are
smoothed, small objects are suppressed and gently connected, particles are disconnected.
Close
Close is dilation followed by erosion so the size of objects is not significantly affected. Contours are
smoothed, small holes and small depressions are suppressed. Very close objects may be connected
together.
Clean
This transformation is also called geodesic opening. The image is eroded first so small objects disappear.
Then, the remaining eroded objects are reconstructed to their original size and shape. The advantage of
this algorithm is that small objects disappear but the rest of the image is not affected.
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Fill Holes
Fills the holes inside objects. This transformation is handy when objects have a rich inner structure with
intensities typical for background. After applying the [Fill Holes] transformation, objects become homogeneous.
Contour
This transformation converts objects into their contours.
Smooth
Smooth affects rough edges of the objects makes them smooth.
Morpho Separate Objects
This transformation detects standalone objects that are connected together and isolates them.
Homotopic Transformations
Homotopic transformations preserve topological relations between objects and holes inside them. Using a
homotopic transformation, an object with 5 holes will be transformed to another object with 5 holes. Two objects
without any holes, even if they are very near each other, will become again two objects without holes, but
likely with a different shape and size. Opening, Closing, Erosion and Dilation are not homotopic transformations.
Typical homotopic transformations in NIS-Elements AR are: [Skeletonize], [Homotopic Marking] and [Thickening].

7.3.1. Connectivity
Applying the above mentioned transformations has some limitations due to digital images rasterization.
When speaking about binary image processing, a binary image is a set of pixels where values 1 represent
objects and values 0 represent background. In the square grid of the image, two possible connectivities can
be used for processing - the 8-connectivity or the 4-connectivity. Look at the picture below. If the 8-connectivity
is used, the two pixels represent one object. If the 4-connectivity is applied, there are two objects in the picture.
NIS-Elements AR works with the 8-connectivity model, so all pixels neighboring by the corner belong to one
object.

7.3.2. Structuring Element = Kernel = Matrix
When applying Erosion, Dilation, Opening or Closing, one of the parameters which determines the transformation result is the selection of kernel (structuring element, matrix) type. There are the following kernels used
in NIS-Elements AR:
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The bright pixel in the center or near the center of the kernel represents its midpoint.

7.3.2.1. Erosion
Lets assume the 1 and 0 values represent object(1) and background(0) pixels. You can imagine the erosion
as the following algorithm:
Move the midpoint of the kernel to every point of the image. Each time, look at the neighboring pixels of the
kernel and make the following decision:
• If there are object(1) pixels in all the positions of the kernel, set the midpoint to object(1).
• If there is at least one background(0) pixel in the kernel, set the midpoint to background(0).

7.3.2.2. Dilation
You can imagine the dilation as the following algorithm:
Move the midpoint of the kernel to every point of the image. Each time, look at the neighboring pixels of the
kernel and make the following decision:
• If there is at least one object(1) pixel in any position of the kernel, set the midpoint to object(1).
• If there are background(0) pixels in all the positions of the kernel, set the midpoint to background(0).

7.3.2.3. Open and Close
Open is performed by eroding the image and then applying a dilation to the eroded image. On the contrary,
Closing is performed as a dilation followed by erosion.

7.3.2.4. Repetition issues
If the midpoint is not in the center, applying erosions or dilations by odd number of iterations causes image
to shift by 1 pixel. Normally, the total image shift would be determined by the number of Iterations (in pixels).
NIS-Elements AR eliminates this shift: it changes the position of the midpoint 1 pixel down-rightwards within
the kernel for even operations. For opening and closing it is possible to eliminate this shift totally. However,
if you run the erode or dilate processes again and again using the kernel with even dimensions and odd
number of iterations, then the shift becomes significant.

7.3.2.5. Examples
Please see the following examples of some of the binary functions applied to an image. In the following sequence of images, the functions were applied subsequently:
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See another sequence of functions:
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The following examples were created by calling each of the functions separately:

Original Image
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7.4. Exporting Results
Some image analysis data and measurement results can be transferred out of NIS-Elements AR so they could
be used further. There is a standard [Export] pull-down menu in some of the control windows (intensity profile,
histogram, measurement, etc...) which enables the export.
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The set of commands of the menu differs according to the type of data (tables or graphs) which can be exported.
Click the arrow button to display the pull-down menu. When you select the destination, the pull down menu
hides and the icon of the selected export type appears on the [Export] button. The export action is performed
after the button is pressed once more.
Export Destinations
It is possible to export tabular data or a graph:
To MS Excel
Tabular data can be exported to MS Excel. A new XLS sheet opens and the table is copied to it automatically.
To File
Tabular data can be exported to an MS Excel sheet (xls) or a text file (tab delimited txt).
To Clipboard
Data tables and graph images can be exported (copied) to MS Windows clipboard. Then the data or the
image can be inserted into any appropriate application (text editor, spreadsheet processor, graphics editor) typically by the [Paste] command.
To Report
Tabular data and graph images can be exported to NIS-Elements AR report. If a report is already opened
for editing, the data/graph will be appended to it. Otherwise, a new report will be created and the exported
data inserted to it.
To Web Browser, To HTML Clipboard
Some tabular data can be exported as a HTML table. It can be displayed in a default Internet browser
(the [Web Browser] option), or the HTML code can be copied to Windows clipboard - ready to be inserted
to any HTML/text editor.
To Printer
Tabular data can be printed directly. This option opens a standard [Print] dialog window where it is possible
to select a printer and print the data.
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Data Export Options
Run the [Options] command and switch to the [Data export] tab or press the [Settings]
export pull-down menu. There are two tabs available:

button within the

Global Settings Options

Export into Microsoft Excel application
Select this option if you want to export the data to MS Excel application. You can choose if the data will
be exported into currently opened file or a new file will be created. Or you can set to export the data to
a specific file. If this file does not exist, it will be created. Choose the path and name of the file to be created/opened.
Set the [Start at column] values (column and row indexes). These values mark the first cell in the MS
Excel application which will hold the exported data.
Export text files into folder
Select this item if you prefer to export the data to a text file. Press the [...] button and specify the target
folder and the file name.
Append exported data after previous exports
If you check this item the existing data will not be overwritten by the new data.
Export also column headers if not appending
Include the titles of columns in the files which are being created or overwritten. If the [Append exported
data after previous exports] is selected, no headers will be included in the export.
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Active target application after export
If you check this item the exported file is opened in the default application (MS Excel or the default text
editor) automatically.
Insert empty lines
Check this item to allow insertion of empty lines in the exported data.
Data export Options
You can modify the amount of data included in each export type.

The control windows which contain the Export to file functionality are listed in the top pull-down menu. Select
the control window of which the export shall be modified.
Export Name
A control window such as [View > Analysis Controls > Annotations and Measurements] stores information
about the measurement in multiple tables according to the measurement type (area, length, etc.). In this
column, you can select the table you would like to modify.
Sheet name
In this column you can define an arbitrary name which will be used to name a sheet or a txt file to which
the data will be exported.
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Options for:
This section of the window enables you to select the items to be included/excluded from the selected
table during export.

7.5. Object Count
The [Object Count] tool is designed for automated object detection and counting. It enables users to threshold
the image, automatically measure the binary objects, and export the measured data to a file in a straightforward
way. Object count can be performed even on Live image. Run the [View > Analysis Controls > Object Count]
command to display the control window.
The recommended workflow through the dialog is to move from left to right, starting with thresholding, then
using restrictions and finally reviewing the result and export out of NIS-Elements AR to a text file or an MS
Excel spreadsheet.

7.5.1. Thresholding the Image

The threshold limits shall be defined by picking object-typical colors from the image. Select one of the following
tools:
•
•
•

[1 point threshold tool]
[3 points circle threshold tool]
[6 points circle threshold tool]

Click inside the image to define typical object areas. The system will detect similar parts of the image and
highlight it by color. The threshold limits are indicated in the histogram and can be further modified by dragging
the limit lines by mouse.
Please, refer to the [Thresholding] chapter for further details on thresholding.
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7.5.2. Applying Restrictions
The number of objects that are included in the results table can be restricted by defining limits. Objects which
do not fit these limits will be left out of the result table.

• Right click to the restrictions field to select one or more of the available measurement features.
• Select the restriction feature you would like to define.
• Move sliders below the histogram to set the limits. The limit values are indicated next to the feature name,
and can be modified by double clicking the indicated value.
• Decide whether the defined interval will be excluded or included - this is done by setting the [Inside/Outside]
option next to the feature name.
• The nearby check box indicates whether the restriction is currently being applied or not. If applied, the histogram below is color, otherwise it is gray.

Note
Infinitude can be defined by entering “oo” or “inf”.
Reset
The [Reset] button on the right side discards restriction settings of all features.
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Bins
This setting determines the number of columns in the histogram.
Restrictions from the Image
A reference object can be picked from the image and used to set the limit values.
• Select the restriction feature you would like to set by mouse. Lets assume you have selected [Circularity].
• Right click the thresholded object which is going to be used as source. A context menu appears.
• Select whether to [INCLUDE] or [EXCLUDE] the selected object and all others with higher/lower circularity.
• The restriction will be applied and indicated by colors within the image.

7.5.3. Results
The following results appear in the results table:
• [Total Area] is the area of the whole image in square pixels or square calibration units.
• [Area Fraction] is the ratio between [Total Area] and the area of the thresholded objects.
• [Number of objects] - number of objects after applying restrictions.
• [Table of results] - measurement results for each object are displayed in this table. Select the columns to
display/hide from the context menu which appears when you right-click one of the column captions.
• [#] - number of selected objects is displayed in the left part of the tool bar. One or more objects can be selected by mouse while holding the [Ctrl] or the [Shift] key.
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Tool Bar
There is a tool bar above the results table which contains the following buttons:
•

•
•
•

[Delete selected objects] removes the selected objects. The objects can be selected by mouse while
holding [Ctrl].
[Invert selection] deselects objects selected by mouse and vice versa.
[Generate binary] erases binary objects which do not meet the restrictions settings.
[Show Object Calatog] opens the [Object Catalog] control window with data source automatically set to
"Object Count".

• [Export] - the measured data can be exported to clipboard or a file using the [Export] button. Please refer
to the [Exporting Results] chapter for further details.
•

•

[Export ND data] - when an ND2 file is opened, the thresholding, measurement, and restrictions are
applied to a single frame. Pressing this button will apply it to all frames of the ND2 document and export
the results to a file or clipboard according to the current export settings.
[Save/Load Object Count configuration] invokes a pull-down menu which enables you to load/save
the current object count settings from/to an external file (*.counting).

• [Use Standard EqDia] - Check this option to enable counting of objects using standard EqDiameter. Value
of the standard EqDiameter parameter can be edited in the field nearby.
•

[Keep updating count] refreshes the measured results each time the binary layer changes (e.g. when
the threshold is modified).
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8. Working with Macros
A macro - an executable sequence of commands - can make the work very effective. NIS-Elements AR
provides a C-like programming language utilizing its internal set of functions. The sequence of functions can
be created either by recording the performed actions, by writing the functions within the macro editor, or by
modifying the command history (the history is recorded automatically during the work). The macro can be
saved to an external (*.mac) file for later use.

8.1. Creating Macros
Recording a Macro
The fastest way to create a macro is to record it.
• Start the NIS-Elements AR macro recorder by selecting the [Macro > Record] command.
• Perform the series of actions you would like to record.
• Finish the recording by the same command again (its name changes to “Stop Recording”)
• It is recommended to check the macro in the macro editor before saving. Run the [Macro > Edit] command
to display it.
• Save the macro to a file via the [Macro > Save As] command.
Creating a Macro from History
You can create a macro using the list of recently performed commands.
1)

Run the [Macro > History] command to display the [Command History] control window:

2)

Push the [Create Macro] button.

3)

Select what portion of the command history will be used in the macro:

147

Selection
This option will use only commands which you have previously selected by mouse within the
[Command History] window. Group selection (holding [Shift] or [Ctrl]) is available.
Whole History
All commands listed in the [Command History] window will be used for the new macro.
4)

After you selected one of the options, the macro editor appears containing the new macro source code.
Use the editor to fine-tune it.
Note
The [Remove Redundant] command is automatically performed before the macro is opened
in the editor.

Writing/Editing a Macro
If you posses programmers skills, a macro can be written by hand in the built-in macro editor. Run the [Macro
> Edit] command to display it.

The macro editor provides:
• Undo/Redo functionality.
• Command insertion from the list of available commands.
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• Interactive command names list. Press [Ctrl+Space] to display a simplified list of all commands while typing
the macro.
• Syntax hints (parameter types and names) appear as you type a command name.
•
•

Bookmarks

can be placed to the code so you can easily roll to the important parts of the macro.

can be placed to the code. A breakpoint forces the macro to stop the execution at a certain
Breakpoints
point so you can check the state of variables and therefore inspect the macro functionality thoroughly.

• Syntax highlighting.
• Help on commands with detailed description.
•

Use the [Save Macro]
macro.

and the [Save Macro As]

commands in the macro editor to save the created

8.2. Running a Macro
NIS-Elements AR provides several ways to run a macro.
• You can run the current macro loaded to NIS-Elements AR by choosing the [Macro > Run] command or by
pressing [F4].
• A [hotkey] combination (Ctrl+Alt+1,2,3 ... 9) can be assigned to it in the [Macro > Options] window.
• You can run a macro at the beginning of the NIS-Elements AR session, by assigning the [StartUp] flag to
the macro in the [Macro > Options] window.
• You can run a macro saved to a disk by using the [Macro > Run From …] command.
• A tool bar button can be assigned to run a macro. See [Modifying Layout].
Breaking the Macro
The macro execution can whenever be stopped by pressing the [Ctrl+Break] key shortcut.

8.3. Macro Language Syntax
Specifies the NIS-Elements AR Macro Language features.
Variable types
The following data types are implemented:
char
text
char8
<-128, 127>
byte
<0, 255>
int
<-32768, 32767>

149

word
<0, 65535>
long
<-2 147 483 648, 2 147 483 647>
dword
<0, 4 294 967 295>
double
<1.7E +/- 308 (15 digits)>
Structures and Unions
Structures and unions are not supported.
Arrays
One and two dimensional arrays are supported.
Local and Global Variables
You should declare local variables at the beginning of macro or function only. You should declare global
variables only at the beginning of macro.You can run two nested macros declaring the same global variables,
but they must be of the same type. You can declare global variables by prefixing the declaration [global]. Eg.:
global int Number_Rows;
global char buffer[200];
The “global” keyword in front of the variable definition assigns the variable to the global scope. Such variable
is then accessible from all function scopes within the macro interpreter.
Statements Supported
for
The [for] statement lets you repeat a statement a specified number of times.
Syntax
for([init-expr]; [cond-expr]; [loop-expr])
statement
First, the initialization (init-expr) is evaluated. Then, while the conditional expression (cond-expr) evaluates
to a non zero value, Statement is executed and the loop expression (loop-expr) is evaluated. When condexpr becomes 0, control passes to the statement the following the for loop.
while
The [while] statement lets you repeat a statement until a specified expression becomes false.
Syntax
while(expression) statement
First, the expression is evaluated. If expression is initially false, the body of the while statement is never
executed, and control passes from the while statement to the next statement in the program. If expression
is true (nonzero), the body of the statement is executed and the process is repeated.
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if, else
Conditionally executes a statement or group of statements, depending on the value of an expression.
Syntax
if(expression) statement1
[else statement2]
The [if] keyword executes statement1 if expression is true (nonzero); if [else] is present and expression
is false (zero), it executes statement2. After executing statement1 or statement2, control passes to the
next statement.
goto
Transfers control of the program execution.
Syntax
goto name;
...
name: statement
You cannot use goto to jump inside the block from outside. E.g. following is not allowed:
goto label;
if(k>5)
{
label:
DilateBinary(3, 5);
FillHoles();
}
You cannot use goto to jump out from the block more then 2 block levels down. E.g. the following is not
allowed:
for(i=0; i<64; i=i+1)
{
for(j=0; j<64; j=j+1)
{
if(a[i] > b[i])
{
value = i;
goto end; // crossing 3 right brackets
}
}
}
end
break
Terminates the execution of the nearest enclosing statement.
Syntax
break;
The [break] keyword terminates the execution of the smallest enclosing [for] or [while] statement in which
it appears. Control passes to the statement that follows the terminated statement.
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continue
Passes control to the next iteration of the statement in which it appears.
Syntax
continue;
The [continue] keyword passes control to the next iteration of the [for] or [while] statement in which it
appears. Within a while statement, the next iteration starts by reevaluating the expression of the while
statement. Within a for statement, the first expression of the for statement is evaluated. Then the compiler
reevaluates the conditional expression and, depending on the result, either terminates or iterates the
statement body.
Statements Not Supported
do, switch, case, default, typedef
These statements are not supported.
Directives
Following directives are supported by the system.
define
The [#define] directive assigns a meaningful name to a constant in a program.
//Syntax
#define identifier token-string
The directive substitutes token-string for all subsequent occurrences of the identifier in the source file.
Token-string can be a value or a string (only for 32-bit version of NIS-Elements).
//Example
#define ERROR_SPRINTF 0
#define MAINDIR "c:\Images"
int main()
{
char buf[256];
int retval;
retval = sprintf(buf, "%s", "MAINDIR");
if(retval == ERROR_SPRINTF)
Beep();
else WaitText(0., buf);
return TRUE;
}
include
Specifies the name of the file to be included.
//Syntax
#include filename
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The [#include] directive includes the contents a file with a specified filename in the source program at
the point where the directive appears.
Example
// if you do not specify the full path, NIS-Elements assumes, that it is a relative path to a main directory
#include "macros\my_macro.h"
#include "c:\NIS-Elements\macros\my_macro1.h"
import
The [#import] directive is used to incorporate information from an external library.
//Syntax
#import("DLLname");
#import function_declaration
NIS-Elements can call functions from external DLL's. You should import the DLL, where the functions
resides and then make a declaration of the functions. You should not import the following system DLL's:
kernel32.dll, user32.dll, gdi32.dll, com32.dll, comdlg32.dll. This feature is available only for 32 bit version
of NIS-Elements.
//Example
#import("luc_13.dll");
#import int RTF_ReplaceVariables(LPSTR destfile, LPSTR sourfile);
#import int RTF_FindQuestion(LPSTR sourfile, LPSTR question, long *length, LPSTR defvar);
#import int RTF_ReplaceQuestion(LPSTR destfile, LPSTR sourfile, LPSTR replacement);
Operators
The following operators are supported by the system. No operator precedence is supported. You should use
brackets to define evaluation order other than implemented in NIS-Elements AR, which is: from right to the
left.
arithmetic operators
+
Addition
Subtraction
*
Multiplication
/
Division
assignment operators
The assignment operator assigns the value of the right operand to the left operand.
=
Addition
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bitwise operators
The bitwise operators compare each bit of the first operand to the corresponding bit of the second operand.
The following bitwise operators are supported.
&
Bitwise AND
|
Bitwise OR
~
One's complement
pointer operators
&
Address of ?
*
Indirection
relational operators
<
Less than
<=
Less than or equal to
>
Greater than
>=
Greater than or equal
==
Equal
!=
Not equal
logical operators
The logical operators perform logical operations on expressions. The following logical operators are supported:
&&
Logical AND
||
Logical OR
!
Logical NOT
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Expression evaluator
Expression evaluator does not support the precedence of operators. It evaluates the expression strictly from
right to left, so you need to use brackets. E.g. 3*4+2 will be evaluated as 3*6 i.e. 18. To force the native precedence of operators, you should write (3*4)+2.
C-like functions
The system can interpret your own C - like functions. An entry point to program is the main() function in your
macro. If main() is not presented, for backward compatibility, the body of the macro is also considered as
"main function". The new macros should use main() as an entry point.
The general C-like functions (also called interpreted functions, as opposed to basic, system functions from
NIS-Elements or LUC32_1.DLL) have the following syntax.
Syntax
int MyFunction(int a, LPSTR str, double d)
{
int retval;
...
return retval;
}
Return Value
The return value can be any basic data types (char, int, word, dword, int, double or pointer).
Parameters
Parameters can be any basic data types (char int, word, dword, int, double or pointer).
Example
int main()
{
char buf[256];
my_function1(buf);
WaitText(0., buf);
return TRUE;
}
int my_function1(char *buf)
{
strcpy(buf, "This function has a pointer to char array as a parameter");
return TRUE;
}
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9. Additional Modules
9.1. 3D Analysis
If you have this module enabled in HASP, some extra commands and features for analysis of multiple binary
layers over Z become available.

9.2. 4D/6D Acquisition
The 4D/6D Acquisition module enables users to combine several acquisition types into one ND experiment.
A multi-dimensional data set comes out from such an experiment.

9.3. API - Advanced Interpreter
This module dramatically extends the macro programing capabilities. It adds the following functionality to the
main application:
User interaction functions
Contains functions, which enable interaction with user like: type value, text, combo boxes, list boxes and
many other Windows standard controls with easy and intuitive code handling.
Support of importing functions from external DLLs
Functions from external DLLs can be imported at the start of the macro and used during the macro execution.
Please see the electronic help for more details.

9.4. Calcium and FRET
Installing the [Calcium and FRET] module adds several tools to the system:
• A control window suited for capturing FRET images.
• Automated FRET calibration algorithm.
• The [Create FRET Image] window for “passive” creation of FRET images from files.
• Calcium ion concentration measurement ability.
Please see the electronic help for more details.

9.5. Database
If the database module was installed, the system can create and control MS Access databases (*.MDB). A
database can help you to efficiently organize your image archives and manage additional information related
to the images. The images themselves are stored on hard disk, only links to them and the additional data are
stored in the database file.
After you install the Database module, the [Database] menu appears in the main tool bar.
Please see the electronic help for more details.
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9.6. AutoQuant Blind Deconvolution
The imperfection of a microscope optical path causes convolution of the original image signal, which makes
the resulting image blurry. Deconvolution algorithms reduce the impact of convolution on the image. Even
though “Blind” means that we do not have to know the convolution parameters accurately, some characteristics
of the optical path (objective) shall be known in order for the deconvolution module to work properly.
Please see the electronic help for more details.

9.7. AutoQuant Real-Time 2D Deconvolution
The imperfection of a microscope optical path causes convolution of the original image signal, which makes
the resulting image blurry. Deconvolution algorithms reduce the impact of convolution on the image. The RealTime Deconvolution module algorithm enables high speed processing and therefore is very suitable for use
on Live signal from cameras. Real-time deconvolution can be applied to the Live image continuously or just
at capture-time. It can be also used for processing saved images.
Please see the electronic help for more details.

9.8. LIM Deconvolution
(requires: [Local Option] )
The imperfection of a microscope optical path causes convolution of the original image signal, which makes
the resulting image blurry. Deconvolution algorithms reduce the impact of convolution on the image. [Standard
2D/3D], [Blind 2D/3D] and [Fast (Wiener)] methods are available.
Please see the electronic help for more details.

9.9. Local Option
Local Option is a pseudo-additional module. When Local Option is installed (see Step 2), NIS-Elements AR
will provide some advanced features which did not pass the quality assurance procedure yet. We recommend
to wait until they are released officially.

9.10. Deconvolution (legacy)
The imperfection of a microscope optical path causes convolution of the original image signal, which makes
the resulting image blurry. Deconvolution algorithms reduce the impact of convolution on the image. The algorithm used is “constrained iterative - maximum likelihood estimation algorithm” (the actual name of the algorithm is “Lucy-Richardson”).
Please see the electronic help for more details.

9.11. Peripheral Device
If a peripheral device is connected to NIS-Elements AR, some extra commands and features become available.
This concerns typically motorized XY stages and Z drives, but also other devices. See [Connected Devices].

9.12. Extended Depth of Focus
The EDF module allows you to combine an existing Z-stack of images into one focused image by picking the
focused regions from each frame and the pieces together.
Please see the electronic help for more details.
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9.13. Filters
This module is aimed at analysis of filters according to the ISO 16232 standard.
Please see the electronic help for more details.

9.14. HDR
(requires: [Local Option] )
The High Dynamic Range module brings the functionality of creating HDR images within NIS-Elements AR.
The following ways to create a HDR image are available:
Automatic capture
Call the [Applications > HDR > Capture Reflection Free Image] command and the HDR image will be
captured using computer-estimated settings
Capture
When the [Applications > HDR > Capture HDR Image] command is called, you will be asked to adjust
the HDR acquisition settings such as number of exposures, exposure time range, camera settings, etc.
Create from files
If a sequence of images which were captured using different exposure times is available, the [Applications
> HDR > Create HDR Image] command can load the images and merge them into a HDR image.
Create from an ND file
Similarly to the situation when the HDR file is created from a sequence of images, it can be as well created
from the frames of on nd2 file. Just run the [Applications > HDR > Create HDR from ND] command.

9.15. Metalo - Grain Size Analysis
After the module installation, a new item called [Metallography] appears in the [Applications] menu. Select
the [Grain Size] command to display the grain size measurement layout.
Features of the Grain Size Analysis Module:
• Measurement of single-phase structures (e.g. Austenite, Aluminium).
• Measurement of two-phase structures (e.g. Ferrite-Austenite, Ferrite-Pearlite).
• Planimetric, Linear, Circular, and Abrams measurement methods.
• Customization of the predefined measurement procedures.
• Support of ASTM and JIS standards (ASTM E112-96, ASTM E1382-97, JISG0551).
• Easy data export.
Please see the electronic help for more details.

9.16. Metalo - Cast Iron Analysis
After the module installation, a new item called [Metallography] appears in the [Applications] menu. Select
the [Cast Iron] command to display the cast iron measurement layout.
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Features of the Cast Iron Analysis Module:
• Graphite classification according to ISO/ASTM/JIS standards (ISO 945, ASTM A247-06, JIS G5502).
• Ferrite/pearlite ratio measurement.
• Customization of the predefined measurement procedures.
• Easy data export.
Please see the electronic help for more details.

9.17. Time Measurement
The time measurement tool enables to record average pixel intensities within Regions Of Interest (ROIs)
during a time interval. The measurement can be performed on Live camera signal or on a saved nd2 file.
Before the measurement is started, regions of interest shall be defined and turned ON.
Please see the electronic help for more details.

9.18. Tracking
Motion characteristics of objects such as living cells can be measured automatically or manually using the
[Tracking] control window.
Please see the electronic help for more details.

9.19. Advanced Tracking
(requires: [Local Option] )
If you have this module enabled in HASP, the [Tracking] module gets extended with several advanced features
such as 3d tracking, etc.
Please see also the ??? chapter for further details.
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10. Supported Cameras
The following cameras are supported by NIS-Elements AR.
• Nikon DS-U1/L1
• Nikon DS-U2/L2
• Nikon DS-U2/L2 - Qi1
• Nikon DS-U2/L2 - Ri1
• Nikon DS-U3/L3
• Nikon DS-U3/L3 - Qi1
• Nikon DS-U3/L3 - Ri1
• Nikon DS-U3/L3 - Vi1/Fi1/Fi2
• Nikon DQCFS
• Andor Ixon
• Andor iKon
• Andor Luca
• Andor Clara
• Vosskühler VDS 1300/2000/4000
• Photometrics Cascade512B
• Photometrics CoolsnapES
• Imaging Source DFG1394
• Hamamatsu ORCA-ER

161

162

Supported Microscopes

11. Supported Microscopes
• Nikon Ci-E Microscope
• Nikon Eclipse 90i/80i Microscope
• Nikon AZ100 Microscope
• Nikon Eclipse LV Series Microscope
• Nikon Eclipse L200 Microscope
• Nikon Eclipse MA200 Microscope
• Nikon MM 400/800 Microscopes
• Nikon Ni-E Microscope
• Nikon Ni-U Microscope
• Nikon TE2000 Microscope
• Nikon TI Microscope
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